Big Event in HDU(HDU-1171)

本文介绍了一个关于0-1背包问题的实际案例,通过解决计算机学院与软件学院设施分配问题来展示如何运用0-1背包算法。具体实现中,首先统计所有设施的总价值,并将其平分为两部分,然后采用0-1背包算法找到最接近平分值的方案。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description

    Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

    The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
    A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

    For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1

Sample Output

20 10
40 40

思路:统计总和,将总和平分后,就是0-1背包问题了

Source Program

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int dp[250001];
int main()
{
    int n;
    int v[51],num[51];
    int sum;
    int i,j,k;

    while(cin>>n && n>0)
    {
        /*初始化*/
        sum=0;
        memset(dp,0,sizeof(dp));

        for(i=1;i<=n;i++)
        {
            cin>>v[i]>>num[i];//输入价值与数量
            sum+=v[i]*num[i];//统计总价值

        }

        for(i=1;i<=n;i++)//物品价值
            for(j=1;j<=num[i];j++)//每个物品数量
                for(k=sum/2;k>=v[i];k-=v[i])//把价值看作体积,从中间开始
                    dp[k]=max(dp[k],dp[k-v[i]]+v[i]);
        cout<<sum-dp[sum/2]<<" "<<dp[sum/2]<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值