HDU 2879 HeHe (积性函数学习)

In the equation X^2≡X(mod N) where x∈[0,N-1], we define He[N] as the number of solutions.
And furthermore, define HeHe[N]=He[1]*……*He[N]
Now here is the problem, write a program, output HeHe[N] modulo M for a given pair N, M.

Input

First line: an integer t, representing t test cases.
Each test case contains two numbers N (1<=N<=10^7) and M (0<M<=10^9) separated by a space.

Output

For each test case, output one line, including one integer: HeHe[N] mod m.

Sample Input

1
2 3

Sample Output

2

(贴学长链接:https://blog.youkuaiyun.com/codeswarrior/article/details/81433946

感觉说不大清楚的是为啥HeHe[n]=2^(n/p1+n/p2+...+n/pk)?

举个例子就清楚了,比如HeHe[6]:

He[1]=1;

He[2]=2=He[2];

He[3]=3=He[3];

He[4]=He[2^2]=2=He[2];

He[5]=2=He[5];

He[6]=He[2*3]=4=He[2]*He[3];

HeHe[6]=He[2]^3*He[3]^2*He[5];

显然,每个质数对因子中有它的He都有贡献。

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <vector>
#include <stack>
#define ll long long
using namespace std;
const int N = 1e7+10;
ll n,m;
bool vis[N];
int prime[N],cnt;
void get_prime()
{
	cnt=0;
	for(int i=2;i<=N-10;i++)
	{
		if(!vis[i])
		{
			prime[cnt++]=i;
			for(int j=i*2;j<=N-10;j+=i)
				vis[j]=1;			
		}
	}
	return ;
}
ll poww(ll a,ll b)
{
	ll ans=1;
	while(b)
	{
		if(b&1) ans=(ans*a)%m;
		a=(a*a)%m;
		b>>=1;
	}
	return ans;
}
int main(void)
{
	get_prime();
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld%lld",&n,&m);
		ll sum=0;
		for(int i=0;i<cnt&&prime[i]<=n;i++)
		{
			sum+=n/prime[i];
		}		
		printf("%lld\n",poww(2,sum));
	}
	
	
	return 0;	
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值