uva 10054 The Necklace(欧拉回路)

这篇博客讲述了作者的妹妹丢失了她的多彩项链,她收集了散落的珠子并请求帮助重建。博主提出了这是一个欧拉回路的问题,并详细解释了解决方案,包括输入输出格式、解题条件和欧拉回路的特点。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

The Necklace 

My little sister had a beautiful necklace made of colorful beads. Two successive beads in the necklace shared a common color at their meeting point. The figure below shows a segment of the necklace:

But, alas! One day, the necklace was torn and the beads were all scattered over the floor. My sister did her best to recollect all the beads from the floor, but she is not sure whether she was able to collect all of them. Now, she has come to me for help. She wants to know whether it is possible to make a necklace using all the beads she has in the same way her original necklace was made and if so in which order the bids must be put.

Please help me write a program to solve the problem.

Input 

The input contains T test cases. The first line of the input contains the integer T.

The first line of each test case contains an integer N ( $5 \leN \le 1000$) giving the number of beads my sister was able to collect. Each of the next N lines contains two integers describing the colors of a bead. Colors are represented by integers ranging from 1 to 50.

Output 

For each test case in the input first output the test case number as shown in the sample output. Then if you apprehend that some beads may be lost just print the sentence ``some beads may be lost" on a line by itself. Otherwise, print N lines with a single bead description on each line. Each bead description consists of two integers giving the colors of its two ends. For $1 \le i \le N ­ 1$, the second integer on line i must be the same as the first integer on line i + 1. Additionally, the second integer on line N must be equal to the first integer on line 1. Since there are many solutions, any one of them is acceptable.

Print a blank line between two successive test cases.

Sample Input 

2
5
1 2
2 3
3 4
4 5
5 6
5
2 1
2 2
3 4
3 1
2 4

Sample Output 

Case #1
some beads may be lost
 
Case #2
2 1
1 3
3 4
4 2
2 2
题目大意:给出一堆珠子,每个珠子有两个颜色,要求判断所给出的珠子是否能连成一个环状的项链。(可以的话要输出)

解题思路:典型的欧拉回路问题,满足1、所有点的入度要等于出度;

2、所有点的联通(这道题目数据没有卡这里)

输出的时候要注意点的自身形成一个环

比如:

1 -> 2

2  -> 3

3 -> 1

2 -> 4

4 -> 2

欧拉回路需要逆序输出。

#include<stdio.h>
#include<string.h>
#define M 52
int num[M];
int map[M][M];
int n;

int get_fa(int x){
	return num[x] != x?get_fa(num[x]):x;}

void print(int k){
	for (int i = 0; i < M; i++)
		if (map[k][i]){
			map[k][i]--;
			map[i][k]--;
			print(i);
			printf("%d %d\n", i , k);
		}
}

int main(){
	int t, bo, k = 1;
	int f[M];
	scanf("%d" ,&t);
	while (t--){
		// Init.
		memset(f, 0, sizeof(f));
		memset(map, 0, sizeof(map));
		bo = 0;
		for (int i = 0; i < M; i++)
			num[i] = i;
        
		// Read.
		scanf("%d", &n);
		for (int i = 0; i < n; i++){
			int a, b;
			scanf("%d%d", &a, &b);
			f[a]++;
			f[b]++;
			map[a][b]++;
			map[b][a]++;
            num[get_fa(a)] = get_fa(b);
		}
        
		// Find.
		int god = 0;
    	for (int i = 0; i < M; i++)
			if (f[i] && get_fa(i) == i)
			{
				god = i;
				break;
			}
        
		// Judge.
		for (int i = 0; i < M; i++){
			bo += f[i] % 2;
			if (f[i] && god != get_fa(i))
					bo++;
		}
        
		// Printf.
		printf("Case #%d\n", k++);
		if (bo > 0)
			printf("some beads may be lost\n");
		else
			print(god);
		if (t)
			printf("\n");
	}
	return 0;}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值