uva 10025 The ? 1 ? 2 ? ... ? n = k problem(算式规律)

该博客介绍了如何解决UVA 10025问题,即通过设置加减运算符使得等式? 1 ? 2 ? ... ? n = k成立。解题思路涉及寻找最小的n值,确保表达式的和大于n,并且考虑通过减去偶数来调整结果。关键在于保证和与n的奇偶性一致。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

 The ? 1 ? 2 ? ... ? n = k problem 

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12 
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701
题目大意:给出一个数, 判断它需要从1~m(可用+、-)填充的算式求得。求m

解题思路:首先, 1~m的和一定要 > n(如果全+都无法表示的话, 更别说有-)其次,找到一个m,使得1~m的和>n之后,因为sum >= n, 所以要减掉一个数, 比如在数字k前面加个-号, 相当于sum - 2 * k,也就是说每次减掉只能是偶数, 那么就要求sum % 2 == n % 2.(负数同理)

#include<stdio.h>

int main(){
	int t, n, sum, i;
	scanf("%d", &t);
	while (t--){
		scanf("%d", &n);
		if (n < 0)
			n = -n;
		for (sum = 0, i = 1; ; i++){
			sum += i;
			if (sum >= n && (sum - n) % 2 == 0){
				printf("%d\n", i);
				break;
			}
		}
		if (t)
			printf("\n");
	}
	return 0;}	

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值