hdu1395 2^n mod n =1 简单数学题

2^x mod n = 1

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15707 Accepted Submission(s): 4865

Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.

Input
One positive integer on each line, the value of n.

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.

Sample Input
2 5

Sample Output
2^? mod 2 = 1 2^4 mod 5 = 1

Author
MA, Xiao
题并不难, 只是用到了数学, 会的秒A, 不会的能想老半天也A不了.

(a%c + b%c) % c = (a+b)%c

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int getAns(int n){
    int x=1;
    int ans=1;
    while(1){
        ans=(ans*2)%n;
        if(ans==1)return x;
        x++;
    }
    return ans;
}
int main(){
    //freopen("hdu.in", "r", stdin);
    //freopen("hdu.out", "w", stdout);
    int n;
    while(cin>>n){
        if(n%2==0 || 1==n){
            printf("2^? mod %d = 1\n",n);
            continue;
        }
        printf("2^%d mod %d = 1\n",getAns(n),n);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值