Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
Source
Recommend
JGShining
#include <iostream>
using namespace std;
int a[21]={0},s[21]={0},b[40]={0},aa,ii=1;
void dfs(int);
int main(int argc, char *argv[])
{
b[2]=1; b[3]=1; b[5]=1; b[7]=1;
b[11]=1; b[13]=1; b[17]=1; b[19]=1;
b[23]=1; b[29]=1; b[31]=1; b[37]=1;
while (cin>>aa){
memset(a,0,sizeof(a));
cout<<"Case "<<ii<<":\n";
a[1]=1; s[1]=1;
dfs(1); ii++;
cout<<endl;
}
return 0;
}
void dfs(int i){
if((i==aa)&&(b[s[i]+s[1]]))
for(int j=1;j<=aa;++j){
cout<<s[j];
if (j<aa) cout<<' ';
else cout<<endl;
}
else
for(int j=2;j<=aa;++j)
if ((!a[j])&&(b[j+s[i]])){
a[j]=1; s[i+1]=j;
dfs(i+1);
a[j]=0; s[i+1]=0; //s[j]=0; 可以去掉
}
}
kdwycz的网站: http://kdwycz.com/
kdwyz的刷题空间:http://blog.youkuaiyun.com/kdwycz