Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54412 Accepted Submission(s): 24090
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
题意:输入一个n,将这n个数进行排列,使得相邻两个数之和为素数。
#include<iostream>
#include<cstdio>
using namespace std;
int num[21],mark[21];
int n;
int p[12]={2,3,5,7,11,13,17,19,23,29,31,37};
int prime(int a)
{
int i;
for(i=0;i<12;i++)
{
if(a==p[i])
return 1;
}
return 0;
}
void print_num()
{
int i;
for(i=1;i<n;i++)
printf("%d ",num[i]);
printf("%d",num[n]);
}
int dfs(int pre,int post,int flag)
{
int i;
if(!prime(pre+post))
{
return 0;
}
num[flag]=post;
if(flag==n&&prime(post+1))
{
print_num();
printf("\n");
return 1;
}
mark[post]=0;
for(i=2;i<=n;i++)
if(mark[i]!=0&&dfs(post,i,flag+1))
break;
mark[post]=1;
return 0;
}
int main()
{
int count,i;
count=1;
while(scanf("%d",&n)!=EOF)
{
for(i=1;i<=n;i++)
{
mark[i]=i;
}
num[1]=1;
printf("Case %d:\n",count++);
if(n==1)
printf("1\n");
for(i=2;i<=n;i++)
dfs(1,i,2);
printf("\n");
}
return 0;
}