A Mathematical Curiosity
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 18909 Accepted Submission(s): 5857
Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
Sample Input
1 10 1 20 3 30 4 0 0
Sample Output
Case 1: 2 Case 2: 4 Case 3: 5
Source
Recommend
JGShining
第一行就是要测试数据的组数(就是那么多的数据作为一组)。 然后下边的数据就是每一小组要测试的数据 并且每一小组以0 0结束,每一行结果要换行,每一组要换行,其中最后一大组结束时不换行。否则,就会Presentation Error。 3 10 1 2 5 3 3 6 8 0 0 2 9 3 7 0 0 6 6 5 4 9 8 0 0 这就表示有三大组,每组的测试数据个数不定,以 0 0 结束。
#include <iostream>
using namespace std;
int main(int argc, char *argv[])
{
int nn,n,m,s,ii,i,j,k;
cin>>nn;
for (i=1;i<=nn;++i){
ii=0;
while (cin>>n>>m && n){
s=0; ++ii;
for (j=1;j<n-1;++j)
for (k=j+1;k<n;++k)
if ((j*j+k*k+m)%(j*k)==0) ++s;
cout<<"Case "<<ii<<": "<<s<<endl;
}
if (i!=nn) cout<<endl;
}
return 0;
}