Fractal
Description
A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales.
A box fractal is defined as below :
Your task is to draw a box fractal of degree n. Input
The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.
Output
For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.
Sample Input 1 2 3 4 -1 Sample Output X - X X X X X - X X X X X X X X X X X X X X X X X X X X X X X X X - X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X - Source |
2014,小KD在战斗!!!
虽然学习递归很久了,递归画分形却是第一次遇到。
《数据结构编程实验》P42
set函数的三个参数代表:从坐标x,y开始,画一个n阶的分形。当n不等于1时,分形可以分为5个部分。依次递归。
画分形就是标记二维数组。全部标记完了整体输出。。。
#include <iostream>
#include <cstring>
using namespace std;
const int MAXN=730;
const int N[8]={0,1,3,9,27,81,243,729};
int n,i,j,map[MAXN][MAXN];
void set(int n,int x,int y);
int main()
{
while (cin>>n && n!=-1){
memset(map,0,sizeof(map));
set(n,1,1);
for (i=1;i<=N[n];++i){
for(j=1;j<=N[n];++j)
if (map[i][j]) cout<<'X';
else cout<<' ';
cout<<endl;
}
cout<<"-\n";
}
return 0;
}
void set(int n,int x,int y){
if (n==1){
map[x][y]=1;
return;
}
set(n-1,x,y);
set(n-1,x+2*N[n-1],y);
set(n-1,x+N[n-1],y+N[n-1]);
set(n-1,x,y+2*N[n-1]);
set(n-1,x+2*N[n-1],y+2*N[n-1]);
return;
}
在POJ的讨论区里面发现一个很牛的代码,短短几行,不明白原理
Posted by jxd at 2006-09-19 13:56:41 on Problem 2083
#include"stdio.h"
#include"math.h"
main()
{
int i,j,n,ii,jj,k;
while(scanf("%d",&n)&&n--!=-1)
{
for(i=0;i<pow(3,n);i++,printf("\n"))
for(j=0;j<pow(3,n);j++)
{
for(ii=i,jj=j,k=0;k<n&&(ii%3+jj%3)%2==0;ii/=3,jj/=3,k++);
printf("%c",32+56*(k==n));
}
printf("-\n");
}
}
kdwycz的网站: http://kdwycz.com/
kdwyz的刷题空间:http://blog.youkuaiyun.com/kdwycz