HDU 5638 Toposort 拓扑排序 优先队列

本文探讨了如何通过删除特定数量的边来优化有向无环图(DAG)的拓扑排序,使其字典序最小,并提供了一种有效算法及其实现细节。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

时间限制:1S / 空间限制:256MB

【在线测试提交传送门】

【问题描述】

    There is a directed acyclic graph with n vertices and m edges. You are allowed to delete exact k edges in such way that the lexicographically minimal topological sort of the graph is minimum possible.
    给定一个有n个顶点,m条边的DAG(有向无环图),删除其中的K条边,使得这个图的拓扑排序的字典序最小。

【输入格式】

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains three integers n, m and k (1≤n≤100000,0≤k≤m≤200000) -- the number of vertices, the number of edges and the number of edges to delete.

For the next m lines, each line contains two integers ui and vi, which means there is a directed edge from ui to vi (1≤ui,vi≤n).

You can assume the graph is always a dag. The sum of values of n in all test cases doesn't exceed 10^6. The sum of values of m in all test cases doesn't exceed 2×10^6.
第一行,一个整数T,表示有T组测试数据,对于每组测试数据:
第一行,包含3个整数n,m和k(1≤n≤100000,0≤k≤m≤200000) 。分别表示顶点数、边数和要删除的边数。
接下来m行,每行包含两个整数ui和vi,表示一条从ui到vi的边(1≤ui,vi≤n)。
输入数据保证是一个DGA,所有测试点中n的和不超过10^6,m的和不超过22×10^6。

【输出格式】

For each test case, output an integer S=(∑i=1ni⋅pi) mod (10^9+7), where p1,p2,...,pn is the lexicographically minimal topological sort of the graph.
对于每组测试数据,输出一个整数S,等于i乘以pi的和,结果对10^9+7取余。其中pi表示字典序最小的拓扑序中的第i个元素。

【输入样例1】

3
4 2 0
1 2
1 3
4 5 1
2 1
3 1
4 1
2 3
2 4
4 4 2
1 2
2 3
3 4
1 4

【输出样例1】

30
27
30

【题目来源】

HDU 5638

【解题思路】

删除的点一定是入度小于等于k,且编号最小的点,使用优先队列维护。

【参考代码】

#include<stdio.h>
#include<iostream>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
const int maxn = 2e5+7;
const int mod = 1e9+7;
vector<int> E[maxn],rE[maxn];
int in[maxn];
int inq[maxn];
int vis[maxn];
priority_queue<int,vector<int>,greater<int> >Q;
void init()
{
    for(int i=0;i<maxn;i++)
        E[i].clear(),rE[i].clear(),in[i]=0;
    memset(inq,0,sizeof(inq));
    memset(vis,0,sizeof(vis));
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        int n,m,k;
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0;i<m;i++)
        {
            int x,y;scanf("%d%d",&x,&y);
            E[x].push_back(y);
            rE[y].push_back(x);
            in[y]++;
        }
        long long Ans = 0;
        for(int i = 1 ; i <= n ; ++ i)
        {
            if(in[i]<=k)
            {
                Q.push( i );
                inq[i] = 1;
            }
        }
        int num = 1;
        while(!Q.empty()){
            int x = Q.top() ; Q.pop(); inq[x] = 0;
            if(k >= in[x]){
                vis[x] = 1 , k -= in[x];
                Ans=(Ans+1ll*num*x)%mod;
                num=num+1;
                for(int i=0;i<E[x].size();i++){
                    int v =E[x][i];
                    if(vis[v]) continue;
                    in[v]--;
                    if(in[v] <= k&&!inq[v]){
                        Q.push(v);
                        inq[v] = 1;
                    }
                }
            }
        }
        printf("%I64d\n",Ans);
    }
}
对于HDU4546问题,还可以使用优先队列(Priority Queue)来解决。以下是使用优先队列的解法思路: 1. 首先,将数组a进行排序,以便后续处理。 2. 创建一个优先队列(最小堆),用于存储组合之和的候选值。 3. 初始化优先队列,将初始情况(即前0个数的组合之和)加入队列。 4. 开始从1到n遍历数组a的元素,对于每个元素a[i],将当前队列中的所有候选值取出,分别加上a[i],然后再将加和的结果作为新的候选值加入队列。 5. 重复步骤4直到遍历完所有元素。 6. 当队列的大小超过k时,将队列中的最小值弹出。 7. 最后,队列中的所有候选值之和即为前k小的组合之和。 以下是使用优先队列解决HDU4546问题的代码示例: ```cpp #include <iostream> #include <vector> #include <queue> #include <functional> using namespace std; int main() { int n, k; cin >> n >> k; vector<int> a(n); for (int i = 0; i < n; i++) { cin >> a[i]; } sort(a.begin(), a.end()); // 对数组a进行排序 priority_queue<long long, vector<long long>, greater<long long>> pq; // 最小堆 pq.push(0); // 初始情况,前0个数的组合之和为0 for (int i = 0; i < n; i++) { long long num = pq.top(); // 取出当前队列中的最小值 pq.pop(); for (int j = i + 1; j <= n; j++) { pq.push(num + a[i]); // 将所有加和结果作为新的候选值加入队列 num += a[i]; } if (pq.size() > k) { pq.pop(); // 当队列大小超过k时,弹出最小值 } } long long sum = 0; while (!pq.empty()) { sum += pq.top(); // 求队列中所有候选值之和 pq.pop(); } cout << sum << endl; return 0; } ``` 使用优先队列的方法可以有效地找到前k小的组合之和,时间复杂度为O(nklog(k))。希望这个解法对你有所帮助!
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值