http://acm.hdu.edu.cn/showproblem.php?pid=2084
Problem Description
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:
有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
已经告诉你了,这是个DP的题目,你能AC吗?
有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?

已经告诉你了,这是个DP的题目,你能AC吗?
Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
Sample Input
1 5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
Sample Output
30
#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long int ll;
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int n;
scanf("%d",&n);
int i,j,a[110][110]={},dp[110][110]={};
for(i=1;i<=n;i++)
{
for(j=1;j<=i;j++) scanf("%d",&a[i][j]);
}
for(i=0;i<110;i++) dp[i][0]=0;
for(i=1;i<=n;i++)
{
for(j=1;j<i;j++) dp[i][j]=a[i][j]+max( dp[i-1][j] , dp[i-1][j-1] );
dp[i][i]=a[i][i]+dp[i-1][i-1];
}
int mx=-1;
for(i=1;i<=n;i++) mx=max(mx,dp[n][i]);
printf("%d\n",mx);
}
return 0;
}