Special Prime
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 390 Accepted Submission(s): 200
Problem Description
Give you a prime number p, if you could find some natural number (0 is not inclusive) n and m, satisfy the following expression:
We call this p a “Special Prime”.
AekdyCoin want you to tell him the number of the “Special Prime” that no larger than L.
For example:
If L =20
1^3 + 7*1^2 = 2^3
8^3 + 19*8^2 = 12^3
That is to say the prime number 7, 19 are two “Special Primes”.

We call this p a “Special Prime”.
AekdyCoin want you to tell him the number of the “Special Prime” that no larger than L.
For example:
If L =20
1^3 + 7*1^2 = 2^3
8^3 + 19*8^2 = 12^3
That is to say the prime number 7, 19 are two “Special Primes”.
Input
The input consists of several test cases.
Every case has only one integer indicating L.(1<=L<=10^6)
Every case has only one integer indicating L.(1<=L<=10^6)
Output
For each case, you should output a single line indicate the number of “Special Prime” that no larger than L. If you can’t find such “Special Prime”, just output “No Special Prime!”
Sample Input
7 777
Sample Output
1 10Hint![]()
这里有个疑问,为什么把n=x³,n+p=y³需要先证明gcd(n²,n+p)=1?
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 1000001
#define LL long long
int prime[N],notprime[N];
void init()
{
for(int i=2;i*i<N;i++)
{
if(!notprime[i])
{
for(LL j=(LL)i*i;j<N;j+=i)
notprime[j]=1;
}
}
}
int main()
{
int n;
init();
while(~scanf("%d",&n))
{
int num=0;
for(int i=1;;i++)
{
int tmp=3*i*i+3*i+1;
if(tmp>n) break;
if(!notprime[tmp])
num++;
}
if(!num) printf("No Special Prime!\n");
else printf("%d\n",num);
}
return 0;
}