GCD
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 13998 Accepted Submission(s): 5346
Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.
Yoiu can assume that a = c = 1 in all test cases.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.
Yoiu can assume that a = c = 1 in all test cases.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
Output
For each test case, print the number of choices. Use the format in the example.
Sample Input
2
1 3 1 5 1
1 11014 1 14409 9
Sample Output
Case 1: 9
Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
问题描述
给定5个整数:a,b,c,d,k,你要在a,b,y中找到x,那么GCD(x,y)= k。 GCD(x,y)表示x和y的最大公约数。由于选项的数量可能非常大,因此只需输出不同数字对的总数。
请注意,(x = 5,y = 7)和(x = 7,y = 5)被认为是相同的。在所有的测试案例中,YOYU都可以假设a = c = 1。
一道做完能疯的题,还是没怎么懂,有空再整理相关知识。从此佩服数学家,佩服到眼冒光的那种!
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
const int MAXN=1e6+10;
int check[MAXN];
int prime[MAXN];
int mu[MAXN];
int tot;
void Moblus()
{//莫比乌斯函数打表
memset(check,0,sizeof(check));
mu[1] = 1;
int tot = 0;
for(int i = 2; i <= MAXN; i++)
{
if( !check[i] )
{
prime[tot++] = i;
mu[i] = -1;
}
for(int j = 0; j < tot; j++)
{
if(i * prime[j] > MAXN) break;
check[i * prime[j]] = 1;
if( i % prime[j] == 0)
{
mu[i * prime[j]] = 0;
break;
}
else
{
mu[i * prime[j]] = -mu[i];
}
}
}
}
long long sum_mu(int a,int b)
{//res为long long型,mu[i]*(a/i)*(b/i)为int型,*1ll就是为了转化为long long
long long rem=0;
for(int i=1;i<=a;i++)
rem+=1ll*mu[i]*(a/i)*(b/i);
long long temp=0;
for(int i=1;i<=a;i++)
temp+=1ll*mu[i]*(a/i)*(a/i);//计算重复的
return rem-temp/2;
}
int main()
{
int n;
int a,b,c,d,k;
Moblus();
scanf("%d",&n);
int ca=0;
while(n--)
{
scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
if(k==0)
{
printf("Case %d: 0\n",++ca);
continue;
}
b/=k;d/=k;
if(b>d)
swap(b,d);
printf("Case %d: %lld\n",++ca,sum_mu(b,d));
}
}