http://acm.hdu.edu.cn/showproblem.php?pid=1114
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
题目大意:完全背包,给你n个硬币的重量和价值,每种硬币可以无限取,给你空的存储罐的重量和目前存储罐的重量,问你存储罐里面最少有多少钱。
思路:完全背包,因为一种物品可以无限取,所以外层循环遍历n种物品,内层循环应该从w[i]向总重量V正推,因为转移方程是dp[i]=min(dp[i],dp[i-w[i]]+v[i]),当前重量为i的情况是从前面重量为i-w[i]的情况转移过来的,正推可以做到一件物品取多件。然后因为本题取的是最小值,自然用min,并把数组初始化为INF,注意dp[0]要置0,(不懂的好好想一想为什么),问最大值的话,用max就好了,数组就初始化为0。当然本题还有另外一种情况,就是根据目前所给硬币的数据,不可能凑出来重量等于目前的存储罐的重量,这时候要打印impossible。然而判断这种情况并不需要什么特殊的操作,只要判断dp[sum]是否为INF即可。给大家举个例子看看,我们给出两种硬币,第一种重量5,价值3;第二种重量7,价值5。我们假设存储罐的重量在17以内。
0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | |
初始化 | 0 | oo | oo | oo | oo | oo | oo | oo | oo | oo | oo | oo | oo | oo | oo | oo | oo | oo |
第一次迭代 | 0 | oo | oo | oo | oo | 3 | oo | oo | oo | oo | 6 | oo | oo | oo | oo | 9 | oo | oo |
第二次迭代 | 0 | oo | oo | oo | oo | 3 | oo | 5 | oo | oo | 6 | oo | 8 | oo | 10 | 9 | oo | 11 |
我们可以看到不能拼凑出来的情况对应的dp数组的值均为INF。因此最后加一个特判就好了。
#include<iostream>
#include<cstdio>
#include<stack>
#include<cmath>
#include<cstring>
#include<queue>
#include<map>
#include<set>
#include<algorithm>
#include<iterator>
#define INF 0x3f3f3f3f
#define EPS 1e-10
typedef long long ll;
typedef unsigned long long ull;
using namespace std;
int v[1005];//价值
int w[1005];//体积
int dp[10005];
//完全背包
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
memset(dp,INF,sizeof(dp));
dp[0]=0;
int v1,v2;
int n,sum;
scanf("%d%d",&v1,&v2);
sum=v2-v1;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d %d",&v[i],&w[i]);
for(int i=0;i<n;i++)
for(int j=w[i];j<=sum;j++)
dp[j]=min(dp[j],dp[j-w[i]]+v[i]);
if(dp[sum]==INF)
printf("This is impossible.\n");
else
printf("The minimum amount of money in the piggy-bank is %d.\n",dp[sum]);
}
return 0;
}