Training little cats

5 Training little cats

题目

Facer's pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the cats to do his exercises. Facer's great exercise for cats contains three different moves: g i : Let the ith cat take a peanut. e i : Let the ith cat eat all peanuts it have. s i j : Let the ith cat and jth cat exchange their peanuts. All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea. You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them.

Input

The input file consists of multiple test cases, ending with three zeroes "0 0 0". For each test case, three integers n, m and k are given firstly, where n is the number of cats and k is the length of the move sequence. The following k lines describe the sequence. (m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have.

Sample Input

3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0

Sample Output

2 0 1

思路

m太大了,要想重复这么多次,只能构建矩阵,用矩阵快速幂

让n++,构建n*n的 ‘’1‘’ 矩阵,最后一列的前n-1存答案,g就在a [b] [n] ++; e,就让该行都为0,s,就swap交换这两行

而且较为稀疏,要再进行优化

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    long long cp[110][110];
} s;
int n;
node juzhen(node a,node b)
{
    node c;
    memset(c.cp,0,sizeof(c.cp));
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=n; j++)
        {
            if(a.cp[i][j])//优化必不可少,否则会超时
            {
                for(int z=1; z<=n; z++)
                    c.cp[i][z]+=a.cp[i][j]*b.cp[j][z];
            }
        }
    }
    return c;
}
node mul(int m)
{
    node ans;
    memset(ans.cp,0,sizeof(ans.cp));
    for(int i=1; i<=n; i++)
        ans.cp[i][i]=1;
    while(m)
    {
        if(m%2)
            ans=juzhen(ans,s);
        m>>=1;
        s=juzhen(s,s);
    }
    return ans;
}
int main()
{
    int k,b,c;
    long long m;
    char a[10];
    while(~scanf("%d%lld%d",&n,&m,&k))
    {
        if(n==m&&m==k&&k==0)
            break;
        n++;
        memset(s.cp,0,sizeof(s.cp));
        for(int i=1; i<=n; i++)
            s.cp[i][i]=1;
        while(k--)
        {
            scanf("%s%d",a,&b);
            if(a[0]=='g')
            {
                s.cp[b][n]++;
            }
            else if(a[0]=='e')
            {
                for(int j=1; j<=n; j++)
                    s.cp[b][j]=0;
            }
            else
            {
                scanf("%d",&c);
                for(int j=1; j<=n; j++)
                {
                    long long d;
                    d=s.cp[b][j];
                    s.cp[b][j]=s.cp[c][j];
                    s.cp[c][j]=d;
                }
            }
        }
        node p=mul(m);
        for(int i=1; i<n; i++)
            printf("%lld ",p.cp[i][n]);
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值