poj2299 逆序数 归并

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 36311 Accepted: 13088

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source


一个经典的归并问题:


#include<iostream>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
int n;
int a[500000];
int temp[500000];
long long merge(int data[],int l,int r){//返回值开始写的是int,因为这个问题数据测了一晚上,非常恼火!
    if(l>=r)
        return 0;
        
    int mid=(l+r)/2;
    long long count=0;
    int cur1=l,cur2=mid+1;
    
    count+=merge(data,l,mid);
    count+=merge(data,mid+1,r);
    int i=l;
    while(cur1<=mid&&cur2<=r){
        if( data[cur1]<=data[cur2] ){       
            temp[i++]=data[cur1];
            cur1++;
        }
        else{
            temp[i++]=data[cur2];
            count+=mid-cur1+1;
            cur2++;
        }
    }

    while( cur1<=mid )
        temp[i++]=data[cur1++];
    while( cur2<=r )
        temp[i++]=data[cur2++];
    for(i=l;i<=r;i++)
        data[i]=temp[i];

    return count;
}
int main(){
    int i;
	long long res;
	freopen("E:\\OJ\\a.txt", "r", stdin);  
	freopen("E:\\OJ\\c.txt", "w", stdout);    
    while( scanf("%d",&n)!=EOF && n!=0 ){
         for(i=0;i<n;i++)
              scanf("%d",&a[i]);
		 //res= merge( a,0,n-1 );
         printf("%lld\n",merge( a,0,n-1 ));//这里写成这种形式vs2012会自动帮忙纠正错误,虽然返回是int,但是dev不会 
    }
    //system("pause");
    return 0;
} 

Count smaller elements on right side 

eg : [4,12,5,6,1,34,3,2] 

o/p [3,5,3,3,0,2,1,0]








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值