Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
这明显是一道最短路径的题,用bfs即可,从三个方向进行广搜,队列大小设置足够大,便可以了。
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<stack>
#include<queue>
using namespace std;
int n, k, t[100010];
int bfs(){
memset(t, -1, sizeof(t));
queue<int> que;
que.push(n);
t[n] = 0;
int temp;
while(!que.empty()){
temp = que.front();
que.pop();
if(temp==k)
break;
int next;
next = temp - 1;
if(next>=0&&next<=100000&&t[next]==-1){
que.push(next);
t[next] = t[temp] + 1;
}
next = temp + 1;
if(next>=0&&next<=100000&&t[next]==-1){
que.push(next);
t[next] = t[temp] + 1;
}
next = temp * 2;
if(next>=0&&next<=100000&&t[next]==-1){
que.push(next);
t[next] = t[temp] + 1;
}
}
return t[temp];
}
int main(){
while(~scanf("%d %d",&n,&k)){
cout << bfs();
}
return 0;
}