POJ2378 Catch That Cow 简单BFS
Catch That Cow
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
- Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
- Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Source
USACO 2007 Open Silver
题目大意:给你两个数n和k,n表示农夫的位置,k表示奶牛的位置,现在农夫去抓牛,农夫可以选择x-1,x+1,x*2得位置变化去抓牛,问最快可以几步抓到。
分析:问的是最快的,基本上就是bfs无疑了,确定 bfs的退出条件就是位置转移到k 也就是 x经过变化后 达到 x==k了。下边就可以写BFS了,用一个数组step[i]表示由x变到i的最小步数,所以 最后答案应该是step[k]。需要注意的是在判断边界情况的时候,最大的不是2*k 我的很多队友都是写这写挂的,因为有可能n比k还有大,所以我设非常的大的数,来判断边界。
#include<queue>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn=100001;
bool vis[maxn];
int step[maxn];
queue <int> q;
int bfs(int n,int k)
{
int head,next;
q.push(n); step[n]=0;
vis[n]=true;
while(!q.empty())
{
head=q.front();
q.pop();
for(int i=0;i<3;i++)
{
if(i==0) next=head-1;
else if(i==1) next=head+1;
else next=head*2;
if(next<0 || next>=maxn) continue;
if(!vis[next])
{
q.push(next);
step[next]=step[head]+1;
vis[next]=true;
}
if(next==k)
return step[next];
}
}
return -1;
}
int main()
{
int n,k;
while(cin>>n>>k)
{
memset(step,0,sizeof(step));
memset(vis,false,sizeof(vis));
while(!q.empty()) q.pop();
if(n>=k) printf("%d\n",n-k);
else printf("%d\n",bfs(n,k));
}
return 0;
}