sdut oj2132数据结构实验之栈二:一般算术表达式转换成后缀式

题目链接:点击打开链接

数据结构实验之栈二:一般算术表达式转换成后缀式

Time Limit: 1000MS Memory limit: 65536K

题目描述

对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。

输入

输入一个算术表达式,以‘#’字符作为结束标志。

输出

输出该表达式转换所得到的后缀式。

示例输入

a*b+(c-d/e)*f#

示例输出

ab*cde/-f*+

提示

 


从原表达式求得后缀式的规律为:

1)  设立操作符栈;
2)  设表达式的结束符为“#”,予设运算符栈的栈底为“#”;

3) 若当前字符是操作数,则直接发送给后缀式。

4)  若当前运算符的优先数高于或等于栈顶运算符,则进栈;

5)  否则,退出栈顶运算符发送给后缀式;
6)   “(” 对它之前后的运算符起隔离作用,“)”可视为自相应左括弧开始的表达式的结束符。

来源

 

代码实现:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <stack>
using namespace std;
#define stackmax 10000
#define stacknum 10000

typedef struct
{
    char *top;
    char *base;
    int stacksize;
}Sqstack;

int initstack(Sqstack &s)
{
    s.base=(char *)malloc(stackmax*sizeof(char ));
    if(!s.base)
        return -1;
    s.top=s.base;
    s.stacksize=stackmax;
    return 0;
}

int Empty(Sqstack &s)
{
    if(s.top==s.base)
        return 0;
    else
        return 1;
}

int push(Sqstack &s,char m)
{
    if(s.top-s.base>=s.stacksize)
    {
        s.base=(char *)realloc(s.base,(s.stacksize+stacknum)*sizeof(char ));
        if(!s.base)
            return -1;
        s.top=s.base+s.stacksize;
        s.stacksize+=stacknum;
    }
    *(s.top++)=m;
    return 0;
}

int pop(Sqstack &s)
{
    if(s.top==s.base)
        return -1;
    s.top--;
    return 0;
}

int Gettop(Sqstack &s,char &m)
{
    if(s.top==s.base)
        return -1;
    m=*(s.top-1);
    return 0;
}

void Match(Sqstack &s,char a[])
{
    char ch;
    for(int i=0;a[i]!='#';i++)
    {
        if(a[i]>='a'&&a[i]<='z')
            printf("%c",a[i]);
        else if(a[i]=='(')///左括号直接进栈
            push(s,a[i]);
        else if(a[i]==')')
        {
            Gettop(s,ch);
            while(ch!='(')///如果栈顶不是左括号,一直输出
            {
                printf("%c",ch);
                pop(s);
                Gettop(s,ch);
            }
            pop(s);///左括号出栈
        }
        else if(a[i]=='+'||a[i]=='-')
        {
            Gettop(s,ch);
            while(Empty(s)!=0&&ch!='(')
            {
                printf("%c",ch);
                pop(s);
                Gettop(s,ch);
            }
            push(s,a[i]);
        }
        else if(a[i]=='*'||a[i]=='/')
        {
            Gettop(s,ch);
            while(Empty(s)!=0&&ch!='('&&(ch=='*'||ch=='/'))
            {
                printf("%c",ch);
                pop(s);
                Gettop(s,ch);
            }
            push(s,a[i]);
        }
    }///for
    while(Empty(s)!=0)///输出栈内的剩余元素
    {
        Gettop(s,ch);
        printf("%c",ch);
        pop(s);
    }
    printf("\n");
}

int main()
{
    Sqstack s;
    char a[255];
    scanf("%s",a);
    initstack(s);
    Match(s,a);
    return 0;
}


 

 

### 创建顺序链表 为了实现顺序建立链表的任务,可以采用C++或Java编程语言来完成。下面提供两种方的具体代码示例。 #### C++ 示例 在C++中定义节点类`Node`以及用于操作链表的方法: ```cpp #include <iostream> using namespace std; struct Node { int data; struct Node* next; }; // 插入新结点到链表末尾 void append(Node*& head, int newData) { Node* newNode = new Node(); newNode->data = newData; newNode->next = NULL; if (head == NULL) { // 如果列表为空,则设置头指针指向新的节点 head = newNode; return; } Node *last = head; while (last->next != NULL) last = last->next; // 找到最后一个节点 last->next = newNode; // 将最后一个节点链接至新节点 } // 显示链表中的所有元素 void displayList(Node* node) { while(node != NULL){ cout << node->data << " "; node = node->next; } } ``` 接着编写主函数读取用户输入并调用上述方法构建链表[^1]: ```cpp int main() { int n; cin >> n; Node* listHead = NULL; for(int i=0;i<n;++i){ int value; cin>>value; append(listHead,value); } displayList(listHead); // 展示最终形成的链表 return 0; } ``` #### Java 示例 对于Java版本,同样先声明内部静态类表示链表节点,并且创建辅助功能来进行插入和打印操作: ```java import java.util.Scanner; class LinkedList { static class Node { int data; Node next; public Node(int d) { this.data = d; this.next = null; } } private static void addAtEnd(Node headRef, int newValue) { Node end = new Node(newValue); if(headRef==null){ headRef=end; return ; }else{ Node temp=headRef; while(temp.next!=null){ temp=temp.next; } temp.next=end; } } private static void printLinkedList(Node node) { while (node != null) { System.out.print(node.data + " "); node = node.next; } } } ``` 随后,在`main()`方法里处理标准输入流并将接收到的数据加入到新建的链表实例当中: ```java public class Main { public static void main(String[] args) { Scanner scanner=new Scanner(System.in); int size=scanner.nextInt(); LinkedList.Node head=null; for(int i=0;i<size;i++){ int num=scanner.nextInt(); LinkedList.addAtEnd(head,num); } LinkedList.printLinkedList(head); // 输出整个链表的内容 } } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值