Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 23580 Accepted Submission(s): 10518
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
题解:大意为n个数,从1开始,相邻的两数之和为素数,用vist[]判断是否访问,path[]走过的数字,
n<20,所以用prime[]来保存素数的值。
用的方法为:DFS 出口的条件为m==n && prime(1+path[n]).
AC code:
#include <iostream>
#include <cmath>
using namespace std;
#define MAX 100
int path[MAX];
int vist[MAX];
int prime[MAX],n;
int isprime(int t) //将素数打印
{
int i;
for(i=2; i<=sqrt(double(t)); i++){
if(t%i==0)
return 0;
}
return 1;
}
void dfs(int m)
{
int i;
if((m==n) && prime[path[1]+path[n]]) //出口条件
{
for(i=1; i<n;i++)
cout<<path[i]<<" ";
cout<<path[i]<<endl;
return ; //回溯
}
else
{
for(i=2; i<=n; i++){
if(!vist[i] && prime[i+path[m]])
{
path[m+1]=i;
vist[i]=1;
dfs(m+1); //如果行的通继续往下搜
vist[i]=0; //退回,并还原
}
}
}
}
int main()
{
int i;
for(i=1; i<60; i++)
{
if(isprime(i))
prime[i]=1;
else
prime[i]=0;
}
int k=1;
while(cin>>n)
{
cout<<"Case "<<k++<<":"<<endl;
memset(vist,0,sizeof(vist));
vist[1]=1;
path[1]=1;
dfs(1);
cout<<endl;
}
return 0;
}