GCD
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 3641 Accepted Submission(s): 1313
Problem Description
Give you a sequence of
N(N≤100,000)
integers :
a1,...,an(0<ai≤1000,000,000)
. There are
Q(Q≤100,000)
queries. For each query
l,r
you have to calculate
gcd(al,,al+1,...,ar)
and count the number of pairs
(l′,r′)(1≤l<r≤N)
such that
gcd(al′,al′+1,...,ar′)
equal
gcd(al,al+1,...,ar)
.
Input
The first line of input contains a number
T
, which stands for the number of test cases you need to solve.
The first line of each case contains a number N , denoting the number of integers.
The second line contains N integers, a1,...,an(0<ai≤1000,000,000) .
The third line contains a number Q , denoting the number of queries.
For the next Q lines, i-th line contains two number , stand for the li,ri , stand for the i-th queries.
The first line of each case contains a number N , denoting the number of integers.
The second line contains N integers, a1,...,an(0<ai≤1000,000,000) .
The third line contains a number Q , denoting the number of queries.
For the next Q lines, i-th line contains two number , stand for the li,ri , stand for the i-th queries.
Output
For each case, you need to output “Case #:t” at the beginning.(with quotes,
t
means the number of the test case, begin from 1).
For each query, you need to output the two numbers in a line. The first number stands for gcd(al,al+1,...,ar) and the second number stands for the number of pairs (l′,r′) such that gcd(al′,al′+1,...,ar′) equal gcd(al,al+1,...,ar) .
For each query, you need to output the two numbers in a line. The first number stands for gcd(al,al+1,...,ar) and the second number stands for the number of pairs (l′,r′) such that gcd(al′,al′+1,...,ar′) equal gcd(al,al+1,...,ar) .
Sample Input
1 5 1 2 4 6 7 4 1 5 2 4 3 4 4 4
Sample Output
Case #1: 1 8 2 4 2 4 6 1
第一个问题求区间的gcd就是一个简单的rmq,关于rmq的介绍推荐一篇博客:http://blog.youkuaiyun.com/zhangjun03402/article/details/50440136
第二问离线枚举每个点开始的每种gcd值,由于一个序列的gcd一定是递减的,而每次递减都至少减少一半,所有gcd的个数只有log(1e9),用二分来查找gcd。这样总的复杂度只有n*logn*logn。由于gcd为离散值,所以我们用map来存储。
#include <iostream>
#include<bits/stdc++.h>
#define ll long long
using namespace std;
const int N=110000;
int n,a[N],f[N][22];
int gcd(int x,int y)
{
return x%y==0?y:gcd(y,x%y);
}
void rmq()
{
for(int i=1;i<=n;i++) f[i][0]=a[i];
for(int j=1;j<18;j++)
{
for(int i=1;i<=n;i++)
{
if((1<<j)+i-1<=n)
{
f[i][j]=gcd(f[i][j-1],f[i+(1<<(j-1))][j-1]);
}
}
}
}
map<int,ll>mp;
int look(int l,int r)
{
int k=(int)log2((double)(r-l+1));
return gcd(f[l][k],f[r-(1<<k)+1][k]);
}
void init()
{
mp.clear();
for(int i=1;i<=n;i++)
{
int g=a[i],j=i;
while(j<=n)
{
g=gcd(g,a[j]);
int l=j,r=n;
while(l<r)
{
int mid=(l+r+1)>>1;
if(look(l,mid)==g) l=mid;
else r=mid-1;
}
mp[g]+=(l-j+1);
j=l+1;
}
}
}
int main()
{
int T,kase=0;
cin>>T;
while(T--)
{
scanf("%d",&n);
for(int i=1;i<=n;i++) scanf("%d",&a[i]);
rmq();
init();
int q;
scanf("%d",&q);
printf("Case #%d:\n",++kase);
while(q--)
{
int l,r;
scanf("%d%d",&l,&r);
int ans1=look(l,r);
printf("%d %lld\n",ans1,mp[ans1]);
}
}
}