The Balance
Time Limit: 5000MS | Memory Limit: 65536K | |
Total Submissions: 6456 | Accepted: 2840 |
Description
Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights.
You are asked to help her by calculating how many weights are required.
You are asked to help her by calculating how many weights are required.

Input
The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases.
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.
Output
The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions.
No extra characters (e.g. extra spaces) should appear in the output.
- You can measure dmg using x many amg weights and y many bmg weights.
- The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition.
- The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.
No extra characters (e.g. extra spaces) should appear in the output.
Sample Input
700 300 200 500 200 300 500 200 500 275 110 330 275 110 385 648 375 4002 3 1 10000 0 0 0
Sample Output
1 3 1 1 1 0 0 3 1 1 49 74 3333 1
给出两种质量分别为 a , b 的砝码,数量不限。要用它们称出质量为 d 的药品。求所用的 a 和 b 的数量。
要求:1. 多种方案合法的情况下输出所用砝码数量最小的。 2. 砝码数量相同的情况下砝码总质量最小的。
首先需要注意的一点是,砝码可以放在两边的盘子里。
天平平衡时,有方程 a * x1 + b * y1 = d + a * x2 + b * y2 . 合并同类项得 a * (x1 - x2) + b * (y1 - y2) = d . 即 a * x + b * y = d。 很明显的一个扩展欧几里得的方程。
所以这个问题就转化成了求这个方程的解的问题。
显然 x 和 y 都是正整数, 并且最优解要满足那两个要求。于是要对解进行调整。
首先,求出最小正整数 x, 再根据 x 求 y。
然后,求出最小正整数 y, 再根据 y 求 x。
或者, 可以直接画出图像来判断发现, 最小值取哪个点与 a b 的大小关系有关。 下面代码就是这个思路。
p * a+q * b = Gcd(a, b) 通解:
p = p0 + b/Gcd(a, b) * t
q = q0 - a/Gcd(a, b) * t(其中t为任意整数)
#include<cstdio>
#include<iostream>
using namespace std;
long long a, b, x, y, d, g;
//扩展欧几里得函数
long long ex_gcd (long long a, long long b, long long& x, long long& y)
{
if( b == 0 )
{
x = 1;
y = 0;
return a;
}
long long g = ex_gcd(b, a%b, y, x);
y = y - a / b * x;
return g;
}
//求绝对值函数
const long long abs ( long long x )
{
return x>0 ? x : -x;
}
//求砝码总质量的函数
const long long weight ( long long x, long long y)
{
return a*abs(x)+b*abs(y);
}
int main ()
{
while( scanf("%lld%lld%lld", &a, &b, &d) != EOF )
{
if( a == 0 && b == 0 && d == 0 ) return 0;
//求解 x, y, g
g = ex_gcd(a, b, x, y);
x *= d/g, y *= d/g;
a = a/g, b = b/g;
//砝码b的质量大于砝码a
if( b >= a )
{
//定位关键值点
while( x >= 0 )
x -= b, y += a;
while( x < 0 )
x += b, y -= a;
//比较零点附近的两个关键的 砝码数量 和 砝码质量,选取最优解
if( b-x+abs(y+a) < x+abs(y) || ( b-x+abs(y+a) == x+abs(y) && weight(x, y) > weight(x-b, y+a) ) )
x -= b, y += a;
}
//砝码b的质量小于等于砝码a
else
{
//定位关键值点
while( y >= 0 )
x += b, y -= a;
while( y < 0 )
x -= b, y += a;
//比较零点附近的两个关键的 砝码数量 和 砝码质量,选取最优解
if( a-y + abs(x+b) < y+abs(x) || (a-y + abs(x+b) == y+abs(x) && weight(x, y) > weight(x+b, y-a) ) )
x += b, y -= a;
}
printf("%lld %lld\n", abs(x), abs(y) );
}
return 0;
}