POJ1769_Minimizing maximizer_DP|线段树优化

本文详细介绍了如何利用动态规划(DP)和线段树优化解决POJ1769题目中的最小最大化问题。通过实例解析输入输出格式,并给出关键的源码解析,帮助读者理解优化过程。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Minimizing maximizer
Time Limit: 5000MS Memory Limit: 30000K
Total Submissions: 4355 Accepted: 1792

Description

The company Chris Ltd. is preparing a new sorting hardware called Maximizer. Maximizer has n inputs numbered from 1 to n. Each input represents one integer. Maximizer has one output which represents the maximum value present on Maximizer's inputs. 

Maximizer is implemented as a pipeline of sorters Sorter(i1, j1), ... , Sorter(ik, jk). Each sorter has n inputs and n outputs. Sorter(i, j) sorts values on inputs i, i+1,... , j in non-decreasing order and lets the other inputs pass through unchanged. The n-th output of the last sorter is the output of the Maximizer. 

An intern (a former ACM contestant) observed that some sorters could be excluded from the pipeline and Maximizer would still produce the correct result. What is the length of the shortest subsequence of the given sequence of sorters in the pipeline still producing correct results for all possible combinations of input values? 

Task 
Write a program that: 

reads a description of a Maximizer, i.e. the initial sequence of sorters in the pipeline, 
computes the length of the shortest subsequence of the initial sequence of sorters still producing correct results for all possible input data, 
writes the result. 

Input

The first line of the input contains two integers n and m (2 <= n <= 50000, 1 <= m <= 500000) separated by a single space. Integer n is the number of inputs and integer m is the number of sorters in the pipeline. The initial sequence of sorters is described in the next m lines. The k-th of these lines contains the parameters of the k-th sorter: two integers ik and jk (1 <= ik < jk <= n) separated by a single space.

Output

The output consists of only one line containing an integer equal to the length of the shortest subsequence of the initial sequence of sorters still producing correct results for all possible data.

Sample Input

40 6
20 30
1 10
10 20
20 30
15 25
30 40

Sample Output

4

Hint

Huge input data, scanf is recommended.





#include<cstdio>
#include<iostream>
#include<cstring>

using namespace std;

const int maxn = 50000 + 1000;
const int inf  = 0x3f3f3f3f;

int Seg[maxn * 4];//线段树维护区间最小值
int n, m;

//线段树查询区间最小值
int Query(int p, int l, int r, int x, int y)
{
	if(l>= x && r <= y) return Seg[p];

	int mid = (l + r) >> 1;
	int res = inf;

	if(x <= mid) res = Query(p<<1, l, mid, x, y);
	if(y > mid) res = min(res, Query(p<<1|1, mid+1, r, x, y));

	return res;
}

//线段树单点更新
void Update(int p, int l, int r, int x, int y)
{
	if(l == r)
	{
		Seg[p] = min(y, Seg[p]);
		return;
	}

	int mid = (l + r) >> 1;

	if(x <= mid) Update(p<<1, l, mid, x, y);
	else Update(p<<1|1, mid+1, r, x, y);

	Seg[p] = min(Seg[p<<1], Seg[p<<1|1]);
}

int main()
{
	//线段树初始化为无穷大
	memset(Seg, inf, sizeof(Seg));

	scanf("%d %d", &n, &m);

	// dp[1] 初始化为 0
	Update(1, 1, n, 1, 0);

	while(m--)
	{
		int s, t;
		scanf("%d %d", &s, &t);

		//状态转移
		int temp = Query(1, 1, n, s, t) + 1;
		Update(1, 1, n, t, temp);
	}

	printf("%d\n", Query(1, 1, n, n, n));

	return 0;
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值