Train Problem I
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 34387 Accepted Submission(s): 12985
Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.



Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
Sample Input
3 123 321 3 123 312
Sample Output
Yes. in in in out out out FINISH No. FINISHFor the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".HintHint
大致题意:
对于给定的两个数列,能否用栈把第一个转化成第二个。若能,输出yes并输出入栈出栈的操作。否则,输出no。每对数列结果的末尾输出一个FINISH。
大体思路:
模拟就好了。
#include<cstdio>
#include<stack>
int n,in,out;
int In[10],Out[10],Ope[20];
int main()
{
//freopen("in.txt","r",stdin);
while(scanf("%d",&n)!=EOF){
scanf("%d%d",&in,&out);
for(int i=n-1;i>=0;i--){
In[i]=in%10,in/=10;
Out[i]=out%10,out/=10;
}
std::stack<int>sta;
for(int i=0,k=0,j=0;i<n;i++){
sta.push(In[i]);
Ope[k++]=0;
while(!sta.empty()&&Out[j]==sta.top()&&j<n){
Ope[k++]=1;
sta.pop();
j++;
}
}
if(sta.empty()) {
printf("Yes.\n");
for(int i=0;i<2*n;i++)
printf("%s\n",(Ope[i]?"out":"in"));
}
else printf("No.\n");
printf("FINISH\n");
}
return 0;
}