Description
There is a square wall which is made of n*n small square bricks. Some bricks are white while some bricks are yellow. Bob is a painter and he wants to paint all the bricks yellow. But there is something wrong with Bob's brush. Once he uses this brush to paint brick (i, j), the bricks at (i, j), (i-1, j), (i+1, j), (i, j-1) and (i, j+1) all change their color. Your task is to find the minimum number of bricks Bob should paint in order to make all the bricks yellow.

Input
The first line contains a single integer t (1 <= t <= 20) that indicates the number of test cases. Then follow the t cases. Each test case begins with a line contains an integer n (1 <= n <= 15), representing the size of wall. The next n lines represent the original wall. Each line contains n characters. The j-th character of the i-th line figures out the color of brick at position (i, j). We use a 'w' to express a white brick while a 'y' to express a yellow brick.
Output
For each case, output a line contains the minimum number of bricks Bob should paint. If Bob can't paint all the bricks yellow, print 'inf'.
Sample Input
2 3 yyy yyy yyy 5 wwwww wwwww wwwww wwwww wwwww
Sample Output
0 15
点灯问题,枚举法,枚举第一行的所有点灯方法,共2^n种,每种方法中第一行确定后,随后可以确定第二行(只点第二行对应第一行不亮的,保证点亮第一行所有),以此类推,最后判断最后一行是否全亮,全亮则存在。
Source
#include<stdio.h>
#include<limits.h>
#include<string.h>
char a[20][20],flag[20][20];
int n,step;
void paint(int i,int j)
{
step++;
flag[i][j]=!flag[i][j];
if(j-1>=0) flag[i][j-1]=!flag[i][j-1];
if(j+1<=n) flag[i][j+1]=!flag[i][j+1];
if(i-1>=0) flag[i-1][j]=!flag[i-1][j];
if(i+1<=n) flag[i+1][j]=!flag[i+1][j];
}
int sample(int number)
{
step=0;
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
if(a[i][j]=='y') flag[i][j]=1;
else flag[i][j]=0;
}
}
for(int j=0;j<n;j++)
if((number&(1<<j))!=0) //每种可能的各位值 number是二进制与每一位上的1相与得对应位的值
paint(0,j);
for(int i=1;i<n;i++)
for(int j=0;j<n;j++)
if(!flag[i-1][j]) paint(i,j);
for(int j=0;j<n;j++)
if(flag[n-1][j]==0) return INT_MAX;
return step;
}
main()
{
int t,i,temp;
int min;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%s",a[i]);
}
memset(flag,0,sizeof(flag));
min=INT_MAX;
for(i=0;i<(1<<n);i++) //对于第一行有2^n种可能
{
temp=sample(i);
if(min>temp) min=temp;
}
if(min<INT_MAX)
printf("%d\n",min);
else printf("inf\n");
}
}