Romantic
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5370 Accepted Submission(s): 2260
Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
…………………………..Write in English class by yifenfei
Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print “sorry” instead.
Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0< a, b<=2^31)
Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put “sorry” instead.
Sample Input
77 51
10 44
34 79
Sample Output
2 -3
sorry
7 -3
Author
yifenfei
Source
HDU女生专场公开赛——谁说女子不如男
题意:求解AX+BY=1的最小非负解x
思路:直接套模板,只要将X%=B,如果X<0就X+=B
#include<stdio.h>
#include<string.h>
using namespace std;
__int64 X, Y;
__int64 gcd(__int64 a, __int64 b) {
__int64 tmp;
while (a % b) {
tmp = a % b;
a = b;
b = tmp;
}
return b;
}
void extend_GCD(__int64 a, __int64 b) {
__int64 X1, Y1;
if (b == 0) {
X = 1;
Y = 0;
return;
}
extend_GCD(b, a % b);
X1 = Y;
Y1 = X - Y * (a / b);
X = X1;
Y = Y1;
}
int main() {
__int64 d, a, b;
while (scanf("%I64d%I64d", &a, &b) != EOF) {
d = gcd(a, b);
if (d != 1) {
printf("sorry\n");
continue;
}
extend_GCD(a, b);
X = X % b;
if (X < 0)
X += b;
Y = (1 - X * a) / b;
printf("%I64d %I64d\n", X, Y);
}
return 0;
}