3月19日 burnside计数

burnside计数公式:

L=1|G|i[1,n]|Zi|=1|G|πGC(π) L = 1 | G | ∑ i ∈ [ 1 , n ] | Z i | = 1 | G | ∑ π ∈ G C ( π )
这里G是置换群,G中的一个元素代表一种置换方法(翻折、旋转等), C(π) C ( π ) 可以理解为对每种置换方法情况不变(重复)的情况。对于旋转 360in 360 i n 角度,其中n是顶点数,就有 kgcd(i,n) k g c d ( i , n ) 种涂色方案。
练习题:

Let it Bead
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6349 Accepted: 4253
Description

“Let it Bead” company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It’s a good thing that bracelets can have different lengths and need not be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced.

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate the number of different bracelets that can be made.
Input

Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.
Output

For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.
Sample Input

1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0
Sample Output

1
2
3
5
8
13
21
代码:

#include<cstdio>
int QP(int a, int b)
{
    int tmp = 1;
    while (b)
    {
        if (b & 1)tmp *= a;
        b >>= 1;
        a *= a;
    }
    return tmp;
}
int gcd(int a, int b)
{
    return b ? gcd(b,a%b) : a;
}
int polya(int n, int k)//k颜色,n珠子
{
    int tmp=0;
    if (n & 1)//奇数
    {
        for (int i = 1; i <= n; i++)
        {
            tmp += QP(k,gcd(n, i));
        }
        tmp += n*QP(k, 1+(n >> 1));
    }
    else
    {
        for (int i = 1; i <= n; i++)
        {
            tmp += QP(k,gcd(n, i));
        }
        tmp += (n >> 1)*QP(k, 1+(n >> 1 ));
        tmp += (n >> 1)*QP(k, n >> 1);
    }
    return tmp;
}
int main()
{
    int n, k;
    while (scanf("%d%d", &k, &n) && k != 0)
    {
        printf("%d\n", polya(n, k)/2/n);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_viceversa

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值