UsacoTraining Chapter1.4 Mixing Milk

Mixing Milk

The Merry Milk Makers company buys milk from farmers, packagesit into attractive 1- and 2-Unit bottles, and then sells that milkto grocery stores so we can each start our day with delicious cerealand milk.

Since milk packaging is such a difficult business in which tomake money, it is important to keep the costs as low as possible.Help Merry Milk Makers purchase the farmers' milk in the cheapestpossible manner. The MMM company has an extraordinarily talentedmarketing department and knows precisely how much milk they needeach day to package for their customers.

The company has contracts with several farmers from whom theymay purchase milk, and each farmer has a (potentially) differentprice at which they sell milk to the packing plant.Of course, a herd of cows can only produce so much milk eachday, so the farmers already know how much milk they will haveavailable.

Each day, Merry Milk Makers can purchase an integer number ofunits of milk from each farmer, a number that is always less thanor equal to the farmer's limit (and might be the entire productionfrom that farmer, none of the production, or any integer in between).

Given:

  • The Merry Milk Makers' daily requirement of milk
  • The cost per unit for milk from each farmer
  • The amount of milk available from each farmer
calculate the minimum amount of money that Merry Milk Makers mustspend to meet their daily need for milk.

Note: The total milk produced per day by the farmers will alwaysbe sufficient to meet the demands of the Merry Milk Makers even ifthe prices are high.

PROGRAM NAME: milk

INPUT FORMAT

Line 1:Two integers, N and M.
The first value, N, (0 <= N <=2,000,000) is the amount of milk that Merry Milk Makers wants per day.
The second, M, (0 <= M <= 5,000) is the number of farmersthat they may buy from.
Lines 2 through M+1:The next M lines each containtwo integers: Pi and Ai.
Pi (0 <= Pi <= 1,000) is price incents that farmer i charges.
Ai (0 <= Ai <= 2,000,000) is the amountof milk that farmer i can sell to Merry Milk Makers per day.

SAMPLE INPUT (file milk.in)

100 5
5 20
9 40
3 10
8 80
6 30

INPUT EXPLANATION

100 5 -- MMM wants 100 units of milk from 5 farmers
5 20 -- Farmer 1 says, "I can sell you 20 units at 5 cents per unit"
9 40 etc.
3 10 -- Farmer 3 says, "I can sell you 10 units at 3 cents per unit"
8 80 etc.
6 30 -- Farmer 5 says, "I can sell you 30 units at 6 cents per unit"

OUTPUT FORMAT

A single line with a single integer that is the minimum costthat Merry Milk Makers must pay for one day's milk.

SAMPLE OUTPUT (file milk.out)

630

OUTPUT EXPLANATION

Here's how the MMM company spent only 630 cents to purchase 100units of milk:
Price
per unit
Units
available
Units
bought
Price *
# units
Total costNotes
520205*20100
9400  Bought no milk from farmer 2
310103*1030
880408*40320Did not buy all 80 units!
630306*30180
Total180100 630Cheapest total cost

题意:有m个农场,需要n单位的牛奶,每个农场能以p元/单位的价格提供a单位牛奶,求最小开销

题解:显然贪心,按单价从小到大排序,按顺序取奶,直到取够n单位

/*
ID: nflsjxc1
TASK: milk
LANG: C++
*/

#include<bits/stdc++.h>

using namespace std;

const int maxn=5005;

int n,m;

struct node
{
	int p,a;
	bool operator < (const node &a)const 
	{
		return p<a.p;
	}
};

node x[maxn];

int main()
{
	freopen("milk.in","r",stdin);
	freopen("milk.out","w",stdout);
	ios::sync_with_stdio(0);
	//cin.tie(0);

	cin>>n>>m;
	for(int i=1; i<=m; i++)
	{
		cin>>x[i].p>>x[i].a;
	}
	
	sort(x+1,x+m+1);
	
	int cost=0;
	for(int i=1;i<=m;i++)
	{
		if(n<x[i].a)
		{
			cost+=x[i].p*n;
			break;
		}
		else
		{
			n-=x[i].a;
			cost+=x[i].a*x[i].p;
		}
	}
	cout<<cost<<'\n';
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值