UVA 401 Palindromes 字符串

本文详细介绍了如何识别并区分普通回文字符串、镜像字符串和镜像回文字符串,提供了识别算法及示例输入输出,并讨论了相关字符及其反转规则。文章还特别注意到了0和O字符的等价性处理,以及单字符镜像情况的处理。通过实例演示了算法的应用,旨在帮助理解字符串识别的基础概念。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Palindromes

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.


A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E" are each others' reverses.


A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A""T""O", and "Y" are all their own reverses.


A list of all valid characters and their reverses is as follows.


CharacterReverseCharacterReverseCharacterReverse
AAMMYY
B N Z5
C OO11
D P 2S
E3Q 3E
F R 4 
G S25Z
HHTT6 
IIUU7 
JLVV88
K WW9 
LJXX  


Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input 

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output 

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.


STRINGCRITERIA
" -- is not a palindrome."if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."if the string is a palindrome and is a mirrored string

Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input 

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA

Sample Output 

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.



Miguel Revilla 2001-04-16

好久没见到过这么恶心的水题了,要是OI模式也许会WA2-3组数据,可惜这个是ACM模式 TAT

要注意两点:
数字0 和 大写字母O 是等价的。 可以先把字符串备份一遍,再把0转换为O来处理
当字符串只有一个字符时,镜面对称的情况。

如果还有问题。。。去论坛看看吧:http://online-judge.uva.es/board/viewtopic.php?f=5&t=5863

#include <iostream>
using namespace std;

const string s1="123456789       ABCDEFGHIJKLMNOPQRSTUVWXYZ";
const string s2="1SE Z  8        A   3  HIL JM O   2TUVWXY5";
const string ss[4]={" -- is not a palindrome.\n\n",
					" -- is a regular palindrome.\n\n",
					" -- is a mirrored string.\n\n",
					" -- is a mirrored palindrome.\n\n"};
string s,temp;
int i,b,b1,b2,len;
int main()
{
	while (cin>>s){
		b1=1; b2=2; b=1; temp=s;
		len=s.size();
		for (i=0;i<len;++i)
			if (s[i]=='0') s[i]='O';
		for (i=0;i<=len/2;++i){
			if (s[i]!=s[len-i-1] && s1[s[i]-49]!=s2[s[len-i-1]-49]){
				b=0; break;
			}
			if (b2 && s[i]==s[len-i-1] && s1[s[i]-49]!=s2[s[len-i-1]-49]) b2=0;
			if (b1 && s1[s[i]-49]==s2[s[len-i-1]-49] && s[i]!=s[len-i-1]) b1=0;
		}
		if (len==1 && s2[s[0]-49]!=' ') b2=2; 
		if (!b) cout<<temp<<ss[b];
		else cout<<temp<<ss[b1+b2];
	}
	return 0;
}

kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.youkuaiyun.com/kdwycz


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值