kmp循环节 power string

本文介绍了一种用于解决字符串幂次分解问题的高效算法。该算法通过构建字符串的后缀数组来快速找到最大重复单元,进而求解字符串能否表示为某个较短字符串的多次重复。文章还提供了一个完整的C++实现示例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <queue>
#include <map>
using namespace std;
int nex[1000005];
char s[1000005];
int main()
{

    while(scanf("%s", s))
  {
    if( strcmp(s, ".") == 0)
        return 0;
    memset( nex, 0, sizeof( nex ));
    nex[0] = -1;
    int i  = 0;
    int j  = -1;
    int h = strlen( s );
    while( i < h )
    {
        if( j == -1 || s[i] == s[j])
        {
            i++;
            j++;
            nex[i] =  j;
        }
        else
            j = nex[j];
    }
    if( h%( h - nex[h]) == 0)
    printf("%d\n", h/( h-nex[h]));
    else
        printf("1\n");
  }
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值