Language:Default
A Chess Game
Description
Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again.
Do you want to challenge me? Just write your program to show your qualification! Input
Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.
Output
There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.
Sample Input 4 2 1 2 0 1 3 0 1 0 2 0 2 0 4 1 1 1 2 0 0 2 0 1 2 1 1 3 0 1 3 0 Sample Output WIN WIN WIN LOSE WIN Hint
Huge input,scanf is recommended.
Source
PKU Monthly,CHEN Shixi(xreborner)
|
题目链接:http://poj.org/problem?id=2425
【题意】在一个有向无环图中,有n个棋子,每次移动棋子只能沿着当前边到下一顶点,没有任何棋子可以移动则为输。
【思路】dfs算出当前点的sg值,异或。
【代码如下】
#include <cstdio>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
int n,m,sg[1100];
vector<int>vct[1100];
int dfs(int x){
if(sg[x] != -1) return sg[x];
int vis[1100];
memset(vis,0,sizeof(vis));
for(int i = 0; i < vct[x].size(); i ++){
dfs(vct[x][i]);
vis[sg[vct[x][i]]] = 1;
}
for(int i = 0; ; i ++){
if(!vis[i]){
sg[x] = i; break;
}
}
return sg[x];
}
int main(){
while(~scanf("%d",&n)){
int t,x;
for(int i = 0; i < n; i ++){
vct[i].clear();
scanf("%d",&t);
while(t --){
scanf("%d",&x);
vct[i].push_back(x);
}
}
memset(sg,-1,sizeof(sg));
for(int i = 0; i < n; i ++) sg[i] = dfs(i);
while(~scanf("%d",&m) && m){
int ans = 0;
while(m --){
scanf("%d",&x);
ans ^= sg[x];
}
if(ans) printf("WIN\n");
else printf("LOSE\n");
}
}
return 0;
}