HDU-1005 Number Sequence(找出最大循环长度)

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 218966    Accepted Submission(s): 55316


 

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

 

Output

For each test case, print the value of f(n) on a single line.

 

 

Sample Input

 

1 1 3 1 2 10 0 0 0

 

 

Sample Output

 

2 5



 

对于f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7 等价于 f(n) = A * f(n - 1) mod 7 + B * f(n - 2) mod 7 ,

简化为f(n) = 部分1 + 部分2,易得部分1和部分2的取值都为[0,6]

所以排列组合之后f(n)的值有7*7=49种可能,所以该式的循环节长度最长就是49了~~

那么只要算出前49个数的值,在对n取模49以下就好了~~

(看这个提交量,突然觉得我有一点笨啊...)

#include<set>
#include<map>
#include<list>
#include<queue>
#include<deque>
#include<cmath>
#include<stack>
#include<cstdio>
#include<string>
#include<bitset>
#include<vector>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;

#define maxn 1000
int num[200];
int main()
{
    int a,b,n;

    while(scanf("%d%d%d",&a,&b,&n) != EOF)
    {
        memset(num,0,sizeof(num));
        if(a == 0 && b == 0 && n == 0)
            break;
        num[1] = 1;
        num[2] = 1;
        for(int i = 3;i <= 49;i++)
            num[i] = (a * num[i - 1] + b * num[i - 2]) % 7;
        printf("%d\n",num[n%49]);
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值