zcmu-1030 age sort (hash散列函数的妙用)

Description

You are given the ages (in years) of allpeople of a country with at least 1 year of age. You know that no individual in that country lives for 100 or more years. Now, you are given a very simple task of sorting all the ages in ascending order.

Input

There are multiple test cases in the input file. Each case starts with an integer (0<n<=1000000), the total number of people. In the next line, there are integers indicating the ages. Input is terminated with a case where = 0. This case should not be processed.

Output

For each case, print a line with space separated integers. These integers are the ages of that country sorted in ascending order.

Sample Input

5 3 4 2 1 5 5 2 3 2 3 1 0

Sample Output

1 2 3 4 5 1 2 2 3 3

试了无数次...这么水的一道题,搞了很久。

思路:

 具体解释写在注释里面很清楚了,如果用数组记录每个人的年龄的话就太浪费空间了呐,因为年龄只有1-100,所以从这一方面考虑,用数组下标记录年龄,用数组记录不同年龄的人数更划算!

#include<stdio.h>
int main()
{
    int i,n,t;
    while(~scanf("%d",&n)){
        int a[101]={0},t=1;
        if(n==0)
            break;
        while(n--){
            scanf("%d",&i);//这里用数组的下标记录年龄
            a[i]++;//数组实际的值就是该年龄的人数
        }
        for(i=1;i<101;i++)//年龄从小到大输出
            while(a[i]-->0){//如果存在这个年龄段的人的话就输出他的年龄,这里注意a[i]每次循环都-1了哟
                if(t){
                    printf("%d",i);
                    t=0;//第一个数前面不用输出空格
                }
                else
                    printf(" %d",i);
            }
        printf("\n");
    }
    return 0;
}

 

当前提供的引用内容并未提及 ZCMU OJ 的题目编号 52131。因此无法直接通过现有引用获取其具体细节或解决方案[^4]。 通常情况下,在解决 OJ 平台上的问题时,可以遵循以下方法来分析和解决问题: ### 题目解析流程 #### 数据结构与算法的选择 对于未明确描述的题目,可以根据常见题型推测可能涉及的数据结构和算法。例如: - 如果涉及到字符串操作,则需考虑大小写敏感性以及特殊字符处理[^1]。 - 若为图论相关问题(如 Domino 倒下模拟),则可采用并查集或其他连通性算法进行求解[^2]。 - 对于最大子数组和等问题,动态规划可能是有效的工具之一[^3]。 以下是基于假设的一个通用框架用于解决潜在类似的编程挑战: ```python def solve_problem(input_data): """ 解决特定输入数据下的计算逻辑 参数: input_data (list): 输入参数列表 返回值: result : 计算后的结果 """ # 初始化变量 n = len(input_data) # 动态规划表初始化 dp = [0]*n dp[0] = max_sum = input_data[0] for i in range(1,n): # 更新状态转移方程 dp[i] = max(dp[i-1]+input_data[i], input_data[i]) # 跟踪全局最优解 if dp[i]>max_sum: max_sum=dp[i] return max_sum ``` 此代码片段仅作为示范用途,并不一定适用于实际编号为 `52131` 的题目情境。 ### 注意事项 当面对新类型的竞赛题目时,请务必仔细阅读原题说明文档,理解边界条件、时间复杂度需求等因素后再着手编写程序实现方案。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值