HDU 1005 ( Number Sequence )

博客给出一个数列定义f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7。输入包含多组测试用例,每组含A、B和n,以三个0结束。要求对每组测试用例计算并输出f(n)的值。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

                                    Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 202775 Accepted Submission(s): 51077

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

#include<iostream>
#include"string.h"
using namespace std;
long int a,b,n,i,c[1000],num=0,j,m=0;
int main()
{
    while(cin>>a>>b>>n)
    {
        if(a==0&&b==0&&n==0)
            break;
        memset(c,-1,sizeof(long int)*1000);
        c[1]=1;
        c[2]=1; 
        if(n==1||n==2)
            cout<<'1'<<endl;
        else
        {
            for(i=3;i<1000;i++)
            {
                c[i]=(a*c[i-1]+b*c[i-2])%7;
            }
            for(i=1;i<100;i++)
            {
                for(j=3;j<100;j++)
                {
                    if(c[j]==c[j+i]&&c[j+i]==c[j+2*i])
                    {
                        continue;
                    }
                    else
                    {
                        m=1;
                        break;
                    }
                }
                if(m==0)
                {
                    num=i;
                    break;
                }
                m=0; 
            }
            cout<<c[3+(n-3)%num]<<endl;
        }
        m=0;
        num=0;
    }
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值