(poj3624)Charm Bracelet(01背包)

本文详细解析了01背包问题的解决方法,包括如何利用滚动数组优化存储空间,并提供了具体的C++实现代码示例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).
Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di
Output
* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints
Sample Input
4 6
1 4
2 6
3 12
2 7
Sample Output
23

分析:01背包,用滚动数组(一维数组)存储最大值

可以直接输入,不用数组存储,节省内存,但是不适合打印路径时候 使用

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
#define mem(a,n) memset(a,n,sizeof(a))
typedef long long LL;
const int N=13000;
const int INF=0x3f3f3f3f;
int dp[N];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        mem(dp,0);
        int w,d;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&w,&d);
            for(int j=m; j>=0; j--)
                if(j>=w)
                {
                    dp[j]=max(dp[j],dp[j-w]+d);
                    printf("dp[%d]=%d\n",j,dp[j]);
                }
        }
        printf("%d\n",dp[m]);
    }
    return 0;
}

用数组存储

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=3500;
int dp[13000],w[maxn],v[maxn];
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=0; i<n; i++)
        scanf("%d%d",&w[i],&v[i]);
    for(int i=0; i<n; i++)
        for(int j=m; j>=w[i]; j--)
            dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
    printf("%d\n",dp[m]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值