Sum It Up(DFS)

Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
Input
The input file will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , … , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , … , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output
For each test case, first output a line containing Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the lineNONE’. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.

Sample Input
4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output
Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

Source
Mid-Central USA 1997
题意:给出所求的sums——t(小于1000),和集合的位数n(不大于12),后面是n个非递增的数(小于100),从给定的n个数中先取若干个的数等于t, 不能出现重复等式,每个数只用一次

分析:此题比较难写的是判重,不能使等式出现重复. 由此想到八数码问题, 有哈希,set,编码解码等判重,那么这道题也能用哈希,set判重

1.set判重

#include<cstdio>
#include<set>
#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
int n,t,a[20],b[20],flag;
set<string>st;
void dfs(int sum,int pos,int cnt)//sum为当前的和,cnt是式子中数字的个数,pos是记录等式数字的下标
{
    if(sum>t) return;//剪枝
    if(sum==t)
    {
        flag=1;///输出等式标记
        string ans="";
        for(int i=1; i<=cnt; i++)
            ans+=(b[i-1]+'0');
        if(st.count(ans)==0)
            for(int i=1; i<=cnt; i++)
            {
                if(i!=cnt) printf("%d+",b[i-1]);
                else printf("%d\n",b[i-1]);
            }
        st.insert(ans);
    }
    for(int i=pos; i<n; i++)
    {
        b[cnt]=a[i];///数组b记录输出等式的数字
        cnt++;
        dfs(sum+a[i],i+1,cnt);
        cnt--;
    }
}
int main()
{
    while(~scanf("%d%d",&t,&n)&&t&&n)
    {
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        printf("Sums of %d:\n",t);
        flag=0;
        dfs(0,0,0);
        if(!flag)
            puts("NONE");
    }
    return 0;
}

2.循环判重

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n,t,a[20],b[20],flag;
void dfs(int sum,int pos,int cnt)
{
    if(sum>t) return;
    if(sum==t)
    {
        flag=1;
        for(int i=1; i<=cnt; i++)
        {
            if(i!=cnt)
                printf("%d+",b[i-1]);
            else printf("%d\n",b[i-1]);
        }
    }
    for(int i=pos; i<n; i++)
    {
        b[cnt]=a[i];
        cnt++;
        dfs(sum+a[i],i+1,cnt);
        cnt--;
        while(i+1<n&&a[i+1]==a[i])///跳过前后两个数相同的情况,避免出现重复的等式
            i++;
        //printf("%d %d %d %d\n",pos,i,cnt,sum);
    }
}

3.哈希表判重

### FastAPI scaf 部署教程 #### 1. 安装 `fastapi-scaf` 工具 为了使用 `fastapi-scaf` 脚手架工具创建和管理项目,首先需要安装该工具。可以通过以下命令完成安装: ```bash pip install fastapi-scaf ``` 此工具提供了便捷的方式生成新的 FastAPI 项目以及新增 API 接口。 --- #### 2. 创建新项目 在本地环境中初始化一个新的 FastAPI 项目可以按照如下方式进行操作: ```bash fastapi-scaf new myproj ``` 上述命令会在当前目录下生成名为 `myproj` 的文件夹,其中包含了完整的 FastAPI 项目结构[^2]。 --- #### 3. 添加自定义 API 进入刚刚创建的项目根目录后,可以根据需求添加额外的 API 接口: ```bash cd myproj fastapi-scaf add myapi ``` 这一步会自动在项目的路由配置中注册新的接口,并提供基础模板供开发者进一步扩展功能逻辑。 --- #### 4. 修改数据库及其他配置项 根据实际业务场景调整相关设置参数,比如连接外部数据源等信息通常位于配置文件内(如 `config.py`)。具体路径取决于所使用的框架版本或者个人偏好设定。 --- #### 5. 安装依赖包并启动服务 确保所有必需库已被正确加载到运行环境当中之后才能正式上线应用实例。执行以下两步即可满足条件: ```bash pip install -r requirements.txt python runserver.py --host=0.0.0.0 --port=8000 ``` 这里推荐使用 ASGI 服务器(例如 Uvicorn 或 Gunicorn),它们能够显著提升性能表现尤其是面对高并发请求时更加稳定可靠。 对于生产环境下建议采用更专业的解决方案,例如通过 Docker 容器化技术封装整个应用程序及其运行时环境;亦或是借助云平台提供的托管型微服务架构简化运维流程降低维护成本。 --- #### 示例代码片段展示如何构建基本的服务端响应机制 以下是基于官方文档给出的一个简单例子说明怎样返回 JSON 数据给客户端调用方: ```python from fastapi import FastAPI app = FastAPI() @app.get("/") async def read_root(): return {"message": "Hello World"} ``` 注意这里的装饰器前缀表明这是一个 GET 请求映射关系,而内部定义了一个异步函数负责处理具体的交互细节[^1]^. ---
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值