Mondriaan’s Dream
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 17605 Accepted: 10105
Description
Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his ‘toilet series’ (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.
Expert as he was in this material, he saw at a glance that he’ll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won’t turn into a nightmare!
Input
The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.
Output
For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.
Sample Input
1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0
Sample Output
1
0
1
2
3
5
144
51205
http://poj.org/problem?id=2411
其实最容易想到的应该是
O(n⋅2m⋅2m)
的方法。
但用轮廓线dp 可以做到
O(n⋅m⋅2m)
用二进制表示状态,1 表示突出影响下一行,0 表示没有影响。(但0,1都是该处用了
转移方程,不要往已知向未知转移这个方向想啊。应该反过来想,这样就方便处理了。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
long long dp[2][1<<11];
int main()
{
int n, m;
while(scanf("%d%d", &n, &m) != EOF && n && m) {
memset(dp, 0, sizeof dp);
dp[0][0] = 1;
long long *crt = dp[0], *next = dp[1];
for(int i = 0; i < n; ++i) {
for(int j = m - 1; ~j; --j) {
for(int s = 0; s < 1<<m; ++s) {
if(s>>j&1) {
next[s] = crt[s&~(1<<j)];
continue;
}
next[s] = crt[s|(1<<j)]; //竖着放
if(j + 1 < m && ~s>>(j+1)&1) {
next[s] += crt[s|(1<<j+1)];//横着放
}
}
swap(crt, next);
}
}
printf("%lld\n", crt[0]);
}
return 0;
}