Arctic Network

本文介绍了一种用于确定无线网络中无线电收发器最小传输距离D的算法,通过使用卫星通信和无线电技术连接北部前哨站,确保任意两个站点间至少存在一条直接或间接的通信路径。算法核心在于构建S个树的森林,移除S-1条最长边,最终求得最小生成树中特定边长作为D。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

解题报告

思维题,理解后就是水题。

我们有S个卫星,那么可以生成S个树的森林,给每个树分一个卫星通信。生成S个树的森林即去除S-1条边。当然我们要去除S-1个较长边,那么剩下的最长边就是答案。

那么就不难得到答案就是:最小生成树的第E-S短的边的值

#include<stdio.h>
#include<cmath>
#include<queue>
#include<algorithm>
#define MAX_V 502
using namespace std;
struct cell{int x,y;}cs[MAX_V];
typedef pair<double,int> P;//first->cost second->id
double val[MAX_V];
bool used[MAX_V];
int V,S,E;

double dis(int a,int b){
    return sqrt((cs[a].x-cs[b].x)*(cs[a].x-cs[b].x)+(cs[a].y-cs[b].y)*(cs[a].y-cs[b].y));
}

double prim(){
    fill(used,used+V,false);
    priority_queue<P,vector<P>,greater<P> > que;
    que.push(P(0,0));
    E=0;

    while(!que.empty()){
        P p=que.top();que.pop();
        double v=p.first;int t=p.second;
        if(used[t]) continue;
        used[t]=true;
        val[E++]=v;

        for(int i=0;i<V;i++)
            if(!used[i])
                que.push(P(dis(t,i),i));
    }

    sort(val,val+E);
    return val[E-S];
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&S,&V);
        for(int i=0;i<V;i++)
            scanf("%d%d",&cs[i].x,&cs[i].y);
        printf("%0.2f\n",prim());
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值