G - Arctic Network
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.
Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1
2 4
0 100
0 300
0 600
150 750
Sample Output
212.13
题意:有N个地方需要连接,其中有无线通讯机器的可以无限距离与其他无线通信机器通信,而有线通信机器需要消耗等于距离的能 量,且有线通信的机器都是统一规格,给出各点位置与无线通信机器数量M,求有线通信机器的规格最小为多少?
题解:prim算法的最小生成树将选中的边的权值都记录下来,然后排序,找到第N-M大的值极为最小规格。
AC代码:#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<cmath>
using namespace std;
int n,t,m,sum;
const int maxn = 600;
const int inf = 0x3f3f3f3f;
double a[maxn][maxn];
double b[maxn];
int x[maxn],y[maxn];
double length[maxn];
int vis[maxn];
int path[maxn];
void prim()
{
for(int i=1;i<=n;i++)
{
vis[i]=0;
path[i]=1;
length[i]=a[1][i];
}
for(int i=1;i<=n;i++)
{
double u=inf;
int v;
for(int j=1;j<=n;j++)
{
if(vis[j]==0&&length[j]<u)
{
u=length[j];
v=j;
}
}
vis[v]=1;
b[sum++]=length[v];
for(int j=1;j<=n;j++)
{
if(vis[j]==0&&length[j]>a[v][j])
{
length[j]=a[v][j];
path[j]=u;
}
}
}
}
double leng(double x1,double y1,double x2,double y2)
{
return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
int main()
{
cin>>t;
while(t--)
{
sum=0;
cin>>m>>n;
for(int i=1;i<=n;i++)cin>>x[i]>>y[i];
for(int i=1;i<=n;i++)
for(int j=i;j<=n;j++)
a[i][j]=a[j][i]=leng(x[i],y[i],x[j],y[j]);
prim();
sort(b,b+n);
printf("%.2f\n",b[n-m]);
}
return 0;
}
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<cmath>
using namespace std;
int n,t,m,sum;
const int maxn = 600;
const int inf = 0x3f3f3f3f;
double a[maxn][maxn];
double b[maxn];
int x[maxn],y[maxn];
double length[maxn];
int vis[maxn];
int path[maxn];
void prim()
{
for(int i=1;i<=n;i++)
{
vis[i]=0;
path[i]=1;
length[i]=a[1][i];
}
for(int i=1;i<=n;i++)
{
double u=inf;
int v;
for(int j=1;j<=n;j++)
{
if(vis[j]==0&&length[j]<u)
{
u=length[j];
v=j;
}
}
vis[v]=1;
b[sum++]=length[v];
for(int j=1;j<=n;j++)
{
if(vis[j]==0&&length[j]>a[v][j])
{
length[j]=a[v][j];
path[j]=u;
}
}
}
}
double leng(double x1,double y1,double x2,double y2)
{
return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
int main()
{
cin>>t;
while(t--)
{
sum=0;
cin>>m>>n;
for(int i=1;i<=n;i++)cin>>x[i]>>y[i];
for(int i=1;i<=n;i++)
for(int j=i;j<=n;j++)
a[i][j]=a[j][i]=leng(x[i],y[i],x[j],y[j]);
prim();
sort(b,b+n);
printf("%.2f\n",b[n-m]);
}
return 0;
}