1146 Topological Order (25 point(s))
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
拓扑排序。
思路:存储有向图,记录结点的入度。然后依次读取给出的排列,每读取一个结点a,其入度应该为0,否则不是拓扑排序。然后去掉这个结点a,需要去掉从这个结点a出发的边,并修改到达结点的入度。
注意点:
1. 由于有多个查询,不能在结点图上直接修改,需要拷贝到临时空间上;
2. 修改入度很容易忘。
重要总结:https://blog.youkuaiyun.com/coderwait/article/details/89185481
#include<iostream>
#include<cstring>
using namespace std;
const int MAX = 1007;
int G[MAX][MAX]={0};
int graph[MAX][MAX];
int I[MAX]={0};
int inDegree[MAX];
int order[MAX];
int N,M,K;
bool topo(){
for(int i=1;i<=N;i++){
int cur = order[i];
if(inDegree[cur]==0){
for(int j=1;j<=N;j++){
if(graph[cur][j]==1){
graph[cur][j]=0;
inDegree[j]--;
}
}
}
else return false;
}
return true;
}
int main(void){
cin>>N>>M;
int a,b;
while(M--){
cin>>a>>b;
G[a][b]=1;
I[b]++;
}
cin>>K;bool first = true;
for(int i=0;i<K;i++){
for(int i=1;i<=N;i++) cin>>order[i];
memcpy(graph,G,sizeof(G));
memcpy(inDegree,I,sizeof(I));
if(!topo()){
if(first) cout<<i,first=false;
else cout<<" "<<i;
}
}
}