1145 Hashing - Average Search Time (25 point(s))
The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.
Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 104. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 105.
Output Specification:
For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted.
where X
is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.
Sample Input:
4 5 4
10 6 4 15 11
11 4 15 2
Sample Output:
15 cannot be inserted.
2.8
哈希表模拟。关键是如何处理碰撞和如何理解平方探测。
对本题存疑:
在本题中,平方探测的增量范围值是 ,我认为这是没有必要的,即使要这样做
即可。而实际上一般是
。
相关链接:
https://blog.youkuaiyun.com/richenyunqi/article/details/81211430
https://blog.youkuaiyun.com/qq_37142034/article/details/87903983
#include<iostream>
#include<cstring>
using namespace std;
bool isPrime(int n){
for(int i=2;i*i<=n;i++){
if(n%i==0) return false;
}
return true;
}
const int MAX = 1e5+13;
int table[MAX]={0};
int main(void){
int Msize,N,M;cin>>Msize>>N>>M;
while(!isPrime(Msize)) Msize++;
int key,q;
while(N--){
cin>>key;bool isOk=false;
for(int i=0;i<Msize;i++){
if(table[(key+i*i)%Msize]==0){
table[(key+i*i)%Msize]=key;
isOk = true;
break;
}
}
if(!isOk) cout<<key<<" cannot be inserted."<<endl;
}
int sum=0;
for(int i=0;i<M;i++){
cin>>q;
for(int k=0;k<=Msize;k++){
int npos = (q+k*k)%Msize;
if(table[npos]==0||table[npos]==q||k==Msize){
//cout<<k+1<<endl;
sum+=(k+1);
break;
}
}
}
printf("%.1f\n",double(sum)/double(M));
return 0;
}