1147 Heaps (30 point(s))

本文深入探讨了堆数据结构的定义及其在计算机科学中的应用。详细解释了如何判断一个完全二叉树是否为最大堆或最小堆,并提供了后序遍历的实现方法。通过示例输入输出,帮助读者理解堆的特性和遍历过程。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1147 Heaps (30 point(s))

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

堆的定义和判断、后序遍历

堆的定义和判断

堆是具有以下性质的完全二叉树:每个结点的值都大于或等于其左右孩子结点的值,称为大顶堆;或者每个结点的值都小于或等于其左右孩子结点的值,称为小顶堆。如下图:

同时,我们对堆中的结点按层进行编号,将这种逻辑结构映射到数组中就是下面这样:

该数组从逻辑上讲就是一个堆结构,我们用简单的公式来描述一下堆的定义就是:

大顶堆:arr[i] >= arr[2i+1] && arr[i] >= arr[2i+2]  

小顶堆:arr[i] <= arr[2i+1] && arr[i] <= arr[2i+2]  

注意点

1. 注意结点范围;

2. 注意后序遍历输出格式。

#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
int M,N;
int levelOrder[1007];
bool isMaxHeap(){
	for(int i=1;i<=N/2;i++){
		if(2*i<=N){
			if(!(levelOrder[i]>=levelOrder[2*i])) return false;
		}
		if(2*i+1<=N){
			if(!(levelOrder[i]>=levelOrder[2*i+1])) return false;
		}
	}
	return true;
}
bool isMinHeap(){
	for(int i=1;i<=N/2;i++){
		if(2*i<=N){
			if(!(levelOrder[i]<levelOrder[2*i])) return false;
		}
		if(2*i+1<=N){
			if(!(levelOrder[i]<levelOrder[2*i+1])) return false;
		}
	}
	return true;
}
vector<int> v;
void postOrder(int root){
	if(2*root<=N) postOrder(2*root);
	if(2*root+1<=N) postOrder(2*root+1);
	v.push_back(levelOrder[root]);
}
int main(void){
	cin>>M>>N;
	while(M--){
		for(int i=1;i<=N;i++) cin>>levelOrder[i];
		if(isMaxHeap()) puts("Max Heap");
		else if(isMinHeap()) puts("Min Heap");
		else puts("Not Heap");
		v.clear();
		postOrder(1);
		for(int i=0;i<v.size();i++){
			if(i==0) cout<<v[i];
			else cout<<" "<<v[i];
		}
		cout<<endl;
	}
	return 0;
}

 

基于html+python+Apriori 算法、SVD(奇异值分解)的电影推荐算法+源码+项目文档+算法解析+数据集,适合毕业设计、课程设计、项目开发。项目源码已经过严格测试,可以放心参考并在此基础上延申使用,详情见md文档 电影推荐算法:Apriori 算法、SVD(奇异值分解)推荐算法 电影、用户可视化 电影、用户管理 数据统计 SVD 推荐 根据电影打分进行推荐 使用 svd 模型计算用户对未评分的电影打分,返回前 n 个打分最高的电影作为推荐结果 n = 30 for now 使用相似电影进行推荐 根据用户最喜欢的前 K 部电影,分别计算这 K 部电影的相似电影 n 部,返回 K*n 部电影进行推荐 K = 10 and n = 5 for now 根据相似用户进行推荐 获取相似用户 K 个,分别取这 K 个用户的最喜爱电影 n 部,返回 K*n 部电影进行推荐 K = 10 and n = 5 for now Redis 使用 Redis 做页面访问次数统计 缓存相似电影 在使用相似电影推荐的方式时,每次请求大概需要 6.6s(需要遍历计算与所有电影的相似度)。 将相似电影存储至 redis 中(仅存储 movie_id,拿到 movie_id 后还是从 mysql 中获取电影详细信息), 时间缩短至:93ms。 十部电影,每部存 top 5 similar movie 登录了 1-6 user并使用了推荐系统,redis 中新增了 50 部电影的 similar movie,也就是说,系统只为 6 为用户计算了共 60 部电影的相似度,其中就有10 部重复电影。 热点电影重复度还是比较高的
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值