1130 Infix Expression (25 point(s))
Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:
data left_child right_child
where data
is a string of no more than 10 characters, left_child
and right_child
are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.
![]() | ![]() |
---|---|
Figure 1 | Figure 2 |
Output Specification:
For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.
Sample Input 1:
8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1
Sample Output 1:
(a+b)*(c*(-d))
Sample Input 2:
8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1
Sample Output 2:
(a*2.35)+(-(str%871))
中缀表达式问题。关键点:把握括号的输出。
两种情况下不输出括号:
1. 对于根节点;
2. 对于既没有左孩子又没有右孩子的结点(即叶子结点)。
注意点:
1. 如何寻找根结点;
2. 树的存储。
个人认为写得很漂亮的代码:
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
struct Node{
string data;int left,right;
};
Node node[25];
int root;
bool visit[25];
void inOrder(int n){
if(!(n==root||(node[n].left==-1&&node[n].right==-1))) cout<<"(";
if(node[n].left!=-1) inOrder(node[n].left);
cout<<node[n].data;
if(node[n].right!=-1) inOrder(node[n].right);
if(!(n==root||(node[n].left==-1&&node[n].right==-1))) cout<<")";
}
int main(void){
int N;cin>>N;
string d;int a,b;
for(int i=1;i<=N;i++){
cin>>node[i].data>>node[i].left>>node[i].right;
visit[node[i].left]=true;
visit[node[i].right]=true;
}
root = find(visit+1,visit+N+1,false)-visit;
inOrder(root);
return 0;
}