UVA 10200 Prime Time (打表)
Prime Time
Euler is a well-known matematician, and, among many other things, he discovered that the formula n 2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41 ∗ 41. Even though this formula doesn’t always produce a prime, it still produces a lot of primes. It’s known that for n ≤ 10000000, there are 47,5% of primes produced by the formula! So, you’ll write a program that will output how many primes does the formula output for a certain interval.
Input
Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You must read until the end of the file.
Output
For each pair a, b read, you must output the percentage of prime numbers produced by the formula in this interval (a ≤ n ≤ b) rounded to two decimal digits.
Sample Input
0 39
0 40
39 40
Sample Output
100.00
97.56
50.00
精度太坑,打表倒不是问题,此题思路很清晰,就是精度卡的坑的很。最后不加1e-8就过不了,加了就过了。
若有幸哪位大牛知道原理的阔不阔以告诉我呀,评论一下就好
#include<cstdio>
#include<cmath>
using namespace std;
const int N = 10000+10;
int cnt[N]={1};
void init() {
for(int i=1; i<N; i++) {
int flag=0;
int t=i*i+i+41;
for(int j=2; j<=sqrt(t); j++) {
if(t%j==0) {
flag=1;
}
}
if(!flag)
cnt[i]=1;
}
for(int i=0;i<=10000;i++){
cnt[i]=cnt[i]+cnt[i-1];
}
}
int main() {
int a,b;
init();
while(scanf("%d%d",&a,&b)!=EOF) {
double s=cnt[b]-cnt[a-1];
printf("%.2lf\n",s/(b-a+1)*100.0+1e-8);//不知道加个1e-8次方有什么用,不是让精确到小数点后两位吗
}
return 0;
}