hdu 3709 Balanced Number 数位DP

Description

A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It’s your job
to calculate the number of balanced numbers in a given range [x, y].

Input

The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).

Output

For each case, print the number of balanced numbers in the range [x, y] in a line.

Sample Input

2
0 9
7604 24324

Sample Output

10
897


这题就是要求balanced Number(以下简称BN),BN就是说可以在这个数中找到一个数位,使得左右的力矩相同
比如12345选取3作为轴心,则左边的权值是1 * 3 + 2 * 2 + 3 * 1
右边的是5 * 1,我们发现无论如何也不能找到一个位置使得其满足,所以这不是一个BN

数位DP裸,显然我们只需要枚举轴心就可以了,然后去算左右的权值,如果算出来的sum为0的话,显然就是可以的,所以我们dfs的框架也很好搭,也就是那个样子,差不多都要写成模板了,于是直接上代码吧

/*
dp[i][j][k]表示现在的len为i,枚举的中心点为j,现在的枚举的数已经组合和为是sum
*/
#include <bits/stdc++.h>
using namespace std;

long long dp[20][20][2000], l, r;
int a[100];

long long dfs( int len, int pos, int sum, bool frog ) {
    if( len < 0 ) return sum ? 0 : 1;
    if( sum < 0 ) return 0;
    if( !frog && dp[len][pos][sum] != -1 ) return dp[len][pos][sum];
    long long ans = 0;
    int up = frog ? a[len] : 9;
    for( register int i = 0; i <= up; i++ ) ans += dfs( len - 1, pos, sum + ( len - pos ) * i, frog && i == up );
    if( !frog ) dp[len][pos][sum] = ans;
    return ans;
}

long long solve( long long n ) {
    if( n < 0 ) return 0;
    int len = 0;
    while( n ) {
        a[len++] = n % 10;
        n /= 10;
    }
    long long ans = 0;
    for( register int i = 0; i < len; i++ ) ans += dfs( len - 1, i, 0, true );
    return ans - ( len - 1 );
}

int main( ) { int T;
    scanf( "%d", &T );
    memset( dp, -1, sizeof(dp) );
    while( T-- ) { 
        scanf( "%lld%lld", &l, &r );
        printf( "%lld\n", solve(r) - solve( l - 1 ) ); 
    }
    return 0;
}

这里写图片描述

内容概要:本文详细介绍了MCP(Model Context Protocol,模型上下文协议)的原理与开发流程。MCP协议起源于2024年11月25日Anthropic发布的文章,旨在解决不同AI模型间工具调用的碎片化问题,提供标准化接入方式,实现多功能应用与创新体验。文章首先解释了MCP的核心概念及其重要性,接着深入探讨了MCP Server和Client的开发步骤,包括项目搭建、工具注册、资源创建、提示符配置以及调试方法。此外,还讲解了MCP的工作原理,特别是C/S架构、JSON-RPC 2.0协议的应用,以及模型如何选择和执行工具。最后,通过一个实际案例展示了如何利用MCP协议构建一个企业微信机器人,实现查询知识库并将结果发送到群聊中。 适合人群:具备一定编程基础,对AI模型集成、标准化开发感兴趣的开发者,尤其是从事大语言模型相关工作的工程师。 使用场景及目标:①解决多模型集成中的工具调用标准化问题;②构建具备多种功能的企业级AI应用,如邮件发送、图像生成等;③学习如何通过MCP协议实现模型决策与工具执行的解耦,提升开发效率和用户体验。 阅读建议:本文适合有一定编程经验的读者,尤其是对AI模型集成有需求的技术人员。建议读者跟随文中提供的示例代码进行实践,理解MCP协议的核心机制,并尝试构建自己的MCP应用。同时,关注官方文档和社区动态,以获取最新的技术支持和开发指南。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值