PoJ 3252 Round Numbers 数位DP

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.

They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start.. Finish

Sample Input

2 12

Sample Output

6


题目描述:

这题是要求a到b里有多少round number(一下简称RN),RN就是二进制表示中0的个数大于等于1的个数的数


题解:

要求RN,显然第一种方法是求小于一个数的数中有多少数满足,这里我们用组合数来求,比如现在在dfs的时候,现在的0和1的个数差值是0,还剩五个位置,现在可以随意填,那么我们就有C(5,3) + C(5,4)+C(5,5)
这是很显然的一种解法,这里说一种另外的解法

现在我们用sta来表示0的个数减去1的个数+32之后的这个数,为什么要+32呢,因为如果先前的0比1少,但是后来如果0比较多的话,仍然可能让他是一个round number,这样+32只是为了方便记忆化,毕竟数组下标不能为负数,这对于我来说是新操作233,%%%

然后我们传一个

int dfs( int pos, int sta, bool lead, bool limit ) 

其中sta的含义已经表示,pos表示当前讨论的是哪一位,从小到大,lead表示是否求前导零,limit表示是否有限制

int dfs( int pos, int sta, bool lead, bool limit ) {
    if( pos == -1 ) return sta >= 32;
    if( !limit && !lead ) return dp[pos][sta];
    int up = limit ? a[pos] : 1;
    int ans = 0;
    for( register int i = 0; i <= up; i++ ) {
        if( lead && i == 0 ) ans += dfs( pos - 1, sta, lead, limit && i == up );
        else                 ans += dfs( pos - 1, sta + ( i == 0 ? 1 : -1 ), lead && i == 0, limit && i == up );
    }
    if( !limit && !lead ) dp[pos][sta] = ans;
    return ans;
}

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int dp[66][66], a[66]; 
int dfs( int pos, int sta, bool lead, bool limit ) { // sta表示0的个数减去1的个数 +32 
    if( pos == -1 ) return sta >= 32;
    if( !limit && !lead && dp[pos][sta] != -1 ) return dp[pos][sta];
    int up = limit ? a[pos] : 1;
    int ans = 0;
    for( register int i = 0; i <= up; i++ ) {
        if( lead && i == 0 ) ans += dfs( pos - 1, sta, lead, limit && i == up );
        else                 ans += dfs( pos - 1, sta + ( i == 0 ? 1 : -1 ), lead && i == 0, limit && i == up );         
    }
    if( !limit && !lead ) dp[pos][sta] = ans;
    return ans;
}

int solve( int n ) {
    int len = 0;
    while( n ) {
        a[len++] = n & 1;
        n >>= 1; 
    }
    return dfs( len - 1, 32, true, true );
} 

int main( ) { int a, b; memset( dp, -1, sizeof(dp) );   
    while( ~scanf( "%d%d", &a, &b ) ) 
        printf( "%d\n", solve( b ) - solve( a - 1 ) );
    return 0;
}

这里写图片描述

内容概要:本文详细介绍了MCP(Model Context Protocol,模型上下文协议)的原理与开发流程。MCP协议起源于2024年11月25日Anthropic发布的文章,旨在解决不同AI模型间工具调用的碎片化问题,提供标准化接入方式,实现多功能应用与创新体验。文章首先解释了MCP的核心概念及其重要性,接着深入探讨了MCP Server和Client的开发步骤,包括项目搭建、工具注册、资源创建、提示符配置以及调试方法。此外,还讲解了MCP的工作原理,特别是C/S架构、JSON-RPC 2.0协议的应用,以及模型如何选择和执行工具。最后,通过一个实际案例展示了如何利用MCP协议构建一个企业微信机器人,实现查询知识库并将结果发送到群聊中。 适合人群:具备一定编程基础,对AI模型集成、标准化开发感兴趣的开发者,尤其是从事大语言模型相关工作的工程师。 使用场景及目标:①解决多模型集成中的工具调用标准化问题;②构建具备多种功能的企业级AI应用,如邮件发送、图像生成等;③学习如何通过MCP协议实现模型决策与工具执行的解耦,提升开发效率和用户体验。 阅读建议:本文适合有一定编程经验的读者,尤其是对AI模型集成有需求的技术人员。建议读者跟随文中提供的示例代码进行实践,理解MCP协议的核心机制,并尝试构建自己的MCP应用。同时,关注官方文档和社区动态,以获取最新的技术支持和开发指南。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值