原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=2955
一:原题内容
Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.
For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.
His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.
His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.
Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Sample Input
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
Sample Output
2 4 6
二:分析理解
一个人抢n个银行,每个银行有一定的钱(整数),和被抓的概率,而这个人有个最大被抓概率,只要超过这个就会被抓,求在不被抓的情况下,最多抢多少。
dp[ i ][ j ]表示抢前i个银行,抢到j块钱的最小被抓概率。只要抢到一个银行,这个银行的所有钱都会被抢。
三:AC代码
#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
using namespace std;
int t;
double maxx;
int n;
struct Node
{
int money;
double grab;
}node[105];
double dp[105][10005];
int main()
{
scanf("%d", &t);
while (t--)
{
for (int i = 0; i < 105; i++)
for (int j = 0; j < 10005; j++)
dp[i][j] = 1.0;
int sum = 0;
scanf("%lf %d", &maxx, &n);
for (int i = 1; i <= n; i++)
{
scanf("%d %lf", &node[i].money, &node[i].grab);
sum += node[i].money;
}
dp[0][0] = 0;
for (int i = 1; i <= n; i++)
for (int j = 0; j <= sum; j++)
{
dp[i][j] = dp[i - 1][j];
if (j - node[i].money >= 0 && dp[i][j] > dp[i - 1][j - node[i].money] + node[i].grab- dp[i - 1][j - node[i].money] * node[i].grab)
dp[i][j] = dp[i - 1][j - node[i].money] + node[i].grab - dp[i - 1][j - node[i].money] * node[i].grab;//去看概率的书就知道为什么了
}
for (int i = sum; i >= 0; i--)
if (dp[n][i] <= maxx)
{
printf("%d\n", i);
break;
}
}
return 0;
}