Beautiful numbers

本文介绍了一种复杂的数位动态规划方法,用于计算特定范围内满足特定条件(即每个非零数字都能整除该数)的美丽数字的数量。通过深入解析代码,读者将了解到如何使用动态规划解决这一问题,包括状态转移方程、边界条件和记忆化搜索的实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Description

Volodya is an odd boy and his taste is strange as well. It seems to him that a positive integer number is beautiful if and only if it is divisible by each of its nonzero digits. We will not argue with this and just count the quantity of beautiful numbers in given ranges.

Input

Multiple test cases.
Each line contains two natural numbers li and ri (1 ≤ li ≤ ri ≤ 9 · 10^18).

Output

One line specifies the answer.

Sample Input

1 9

12 15

Sample Output

9

2

一道很强的数位dp,感觉要去练下记搜了= =

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int Maxn=2520;
ll l,r,c[20],idx[Maxn+5],f[20][Maxn+5][50];
ll gcd(ll a,ll b){
	return !b?a:gcd(b,a%b);
}
#define lcm(a,b) a/gcd(a,b)*b
ll dp(int x,ll lef,ll lcm,bool flag){
	if(!x)return lef%lcm==0;
	if(!flag&&~f[x][lef][idx[lcm]])return f[x][lef][idx[lcm]];
	int limit=flag?c[x]:9;
	ll ret=0;
	for(int i=0;i<=limit;++i){
		ll Lcm=i?lcm(lcm,i):lcm;
		ret+=dp(x-1,(lef*10+i)%Maxn,Lcm,flag&&i==limit);
	}
	if(!flag)f[x][lef][idx[lcm]]=ret;
	return ret;
}
ll Solve(ll x){
	for(c[0]=0;x;x/=10)c[++c[0]]=x%10;
	return dp(c[0],0,1,1);
}
int main(){
	for(int i=1;i<=Maxn;++i)
		if(Maxn%i==0)idx[i]=++idx[0];
	memset(f,-1,sizeof(f));
	while(~scanf("%lld%lld",&l,&r)){
		cout<<Solve(r)-Solve(l-1)<<"\n";
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值