吃土豆
时间限制:
1000 ms | 内存限制:
65535 KB
难度:
4
-
描述
-
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
Now, how much qualities can you eat and then get ?
-
输入
-
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M,N<=500.
输出
- For each case, you just output the MAX qualities you can eat and then get. 样例输入
-
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6
样例输出
-
242
//横向dp,最后纵向dp注意最后的max
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int map[500+10][500+10]={0};
int main()
{
int m,n;
while(cin>>m>>n)
{
for(int i=1; i<=m; i++)
for(int j=1; j<=n; j++)
cin>>map[i][j];
for(int i=1; i<=m; i++)
{
for(int j=3; j<=n; j++)
{
map[i][j]+=max(map[i][j-2],map[i][j-3]);
}
map[i][n]=max(map[i][n],map[i][n-1]);//注意是在两个间取最大
}
for(int i=3; i<=m; i++)
{
map[i][n]+=max(map[i-3][n],map[i-2][n]);
}
printf("%d\n",max(map[m][n],map[m-1][n]));
}
return 0;
}//ac