poj 2299 Ultra-QuickSort(离散化+树状数组求逆序数)

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 67585 Accepted: 25315

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source


当数列中的 例如 9 1 0 5 4,可以映射为5 2 1 4 3 然后用树状数组求逆序数
1.首先从小到大进行编号,从而实现离散化
2.然后利用树状数组来统计每个数前面比自己大的数的个数

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
const int MAXN=500010;
int c[MAXN];
int b[MAXN];//保存离散化之后的值 
int n;
struct Node
{
    int index;//序号
    int v;//原值 
}node[MAXN];

bool cmp(Node a,Node b)
{//按照原值排序 
    return a.v<b.v;
}
int lowbit(int x)
{
    return x&(-x);
}

void add(int i,int val)
{
    while(i<=n)
    {
        c[i]+=val;
        i+=lowbit(i);
    }
}

int sum(int i)
{
    int s=0;
    while(i>0)
    {
        s+=c[i];
        i-=lowbit(i);
    }
    return s;
}

int main()
{
    while(scanf("%d",&n),n)
    {
        for(int i=1;i<=n;i++)
        {//下标从一开始,防止元素为0 
            scanf("%d",&node[i].v);
            node[i].index=i;
        }
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        //离散化 
        sort(node+1,node+n+1,cmp);
        for(int i=1;i<=n;i++)
        {
            b[node[i].index]=i;
        }
        long long  ans=0;
        //一开始c数组都是0,然后逐渐在b[i]处加上1;
        for(int i=1;i<=n;i++)
        {
        	add(b[i],1);
            ans+=sum(n)-sum(b[i]);
            //也可以ans+=i-sum(b[i]);
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值